Error trying to obtain the database metadata information?

Topics: July and December Releases Forum
Mar 12, 2007 at 3:34 AM
I'm currently running Visual Studio Team System 2005 on Windows Vista Ultimate. I installed the June 2006 GAX and the December 2006 Web Service Software Factory using the "Command prompt running as administrator" trick and everything appears to install properly.

Inside Visual Studio, I do the following:

1) Create a WCF Service C# guidance solution.
2) Add my SQL Server 2005 connection string to the web.config in the Host project under Tests.
3) Right click the BusinessEntities project and select the "Create business entities from database" option.
4) Select the connection string that I added in step 2 and click next.

When it tries to go onto the "Specify tables" step, it pops up an error that says:
"There was an error trying to obtain the database metadata information."

The same thing occurs when I attempt this with a SQL Server 2005 Express database. I have no idea how to correct this issue, and I haven't seen anyone else having the same problems that are currently working with this on Windows Vista. I do have VS SP1 installed as well as the SQL Server SP2 beta release for Vista. I've also went through the steps to add my Windows account as an administrator in both SQL Server and SQL Server Express.

Any other suggestions on what could be causing this?

Mar 12, 2007 at 3:37 AM
As one final note, I'm unable to move past the "Specify tables" step. The window shows my connection string with a check box, but no tables are displayed beneath it. Since I'm unable to select any tables, the next button remains disabled.
Mar 14, 2007 at 4:57 AM
Did you check that the generated connection string is pointing to a valid DB and the connection is working? Can you post the connection string just to check if the values make sense?
By your description, it seems to be a valid environment (quite similar to mine) so it might be some SQL configuration that may be causing the problem.

Mar 14, 2007 at 5:08 PM
Hey Charly,

I just realized what the problem was today. I was missing providerName="System.Data.SqlClient" on the connection string in my web.config for whatever reason. As soon as I added that, everything went smoothly as I originally expected.

Thanks for replying. :)

Mar 22, 2007 at 9:05 PM
I'm running into the same error, but while trying to retrieve Oracle 10g tables.
The initial connection string created by the Add Database Connection tested fine and I've tried every connection string combination in the config file that I can think of, particularly altering providerName="System.Data.OracleClient".
Any help would be appreciated.
Mar 23, 2007 at 4:35 AM
Are you running the DA guidance package modofied for Oracle ? (Oracle Schema Discovery).
Notice both links in that page.

Mar 26, 2007 at 2:54 PM
Yes, I replaced the original DA guidance package with the packages provided at Oracle Schema Discovery. I compiled the new package but the result is the same. Am I missing any steps?
Thanks for your help.
Mar 27, 2007 at 4:24 PM
Perhaps you can ask Philippe about this.
He was the author of the Oracle port (OracleSchemaDiscovery and WCF).
Apr 26, 2007 at 8:24 PM
I had this issue and within the connection string, set "source=localhost" instead of "source=./SQLexpress" and it worked
Feb 27, 2008 at 3:04 PM
I installed the DA guidance package modified for Oracle and tried for Oracle10g.

The test connection gets successful but does not go beyond specify database connection properties.

Onclick to the Specify tables or Specify Stored procedures and error is thrown :error trying to obtaindatabase metadat information. Am I skipping some other steps?

Feb 27, 2008 at 6:17 PM
You can try searching in the Repository Factory Forum or in this forum with "Oracle" keyword. You may also check out this thread
Feb 28, 2008 at 10:30 AM
I had followed the 14 steps mentioned in the thread .The only different step I did was ,wrote the connectionstring myself rather than letting the tool to generate it.This worked.Thanks.