Issue with recipes after getting registered through an installer

Topics: General Discussion Forum, July and December Releases Forum
Mar 8, 2007 at 5:39 AM
Hi all,
We are into a project using service factory. Now we have created our own recipes and then get it package in an installer. This installer also has some custom actions and pre-requisites incorporated in the guidance project itself. Now when i did a register through the guidance product, all the recipes were working fine and working as per the expected behavior.

Now when on using this installer and doing the installation as well registration through it, i detected that one of the wizard page is going for a resize and then another recipe closed abruptly without any error/warning message displayed. Since I don't get any error message, i'm not able to find the cause of this issue and solve it

Can anyone guide me as to what might be the issue? Help welocome from anyone who has earlier faced this type of issue or known aboout this issue....

Thanks,
ThunderRock
Developer
Mar 8, 2007 at 4:44 PM
By your description, it seems that your custom page is throwing an exception and that will cause to end the wizard execution and close it without showing up any error dialog. You have two options.

  1. Look into the output window (Microsoft Recipe Framework) and check the trace output.
  2. Debug the package and check where is failing the page that throws that exception
If you for #2 (recommended) you may get some info on how to debug guidance packages here Debugging Guidance Packages.

Charly