Dual naming on Generated Service Software Factory dlls

Topics: General Discussion Forum
Nov 3, 2009 at 9:25 PM

Is it normal behaviour to get duplicate naming on the generated dlls (eg. TestServiceImpl.ServiceImplementation.ServiceImplementation.dll)? My first though was that I was naming the project TestServiceImpl.ServiceImplementation and then the Service Software Factory was adding the additional ServiceImplementation naming. However, when I double-checked my naming that was not the case. I tried the generation a couple of times with different naming, but with the same duplicate name dll result. When I go into the project details and look at the dll naming, sure enough it has the duplicate names in it. I can change the dll naming by changing the project properties, but is there a way to avoid this type of behaviour or is there a configuration change I can do? I used the vanilla install of the February 2008 VS 2008 edition with no customizations just out of the box.

Nov 3, 2009 at 10:09 PM


When you run the wizard dialog for adding the project structure (ASMX or WCF) which is the name that you set?

Is it "TestServiceImpl"?

Nov 4, 2009 at 4:21 AM


The name I use is "TestService" in the dialog box and the project structure is WCF.

Nov 4, 2009 at 11:52 AM

Some questions:

  1. Are you ising the binary or source version?
  2. Did you try with other names? (i.e. not using "Service" as prefix)
  3. In that case, did you get the same behavior? 



Nov 4, 2009 at 7:47 PM

1. Binary version.

2. I tried with other names and same result. I tried using just Foo and ended up with FooImpl.ServiceImplementation.ServiceImplementation.dll.

3. Got same behaviour.

Nov 5, 2009 at 2:39 AM

Sorry but I got a couple more questions:

  1. Is this your first installation of WSSF or you had a previous version before?
  2. Do you have VS2008+SDK2008+Prereq or you have also VS2005+SDK2005 ?
  3. Are you unfolding this template (running this recipe) in a C# solution or VB.NET?
Nov 5, 2009 at 4:27 AM

1. First installation of WSSF.

2. I have VS 2005 + SDK and VS 2008 + SDK.

3. Running the recipe in C#.

Nov 6, 2009 at 7:19 PM

This seem to be an issue with Visual Studio and how is handling the Template Parameters and in particular the $safeprojectname$ value located in the solution and project templates that use the WSSF package. I'm not sure which was the problem that caused this but I know some issues may happend when running side by side 2005 and 2008, in particular with both SDKs.

If possible, try installing WSSF in a VS2008+SDK only environment and check this out. As far as I remember this issue was not previously documented so take this with a grain of salt.

If you can't find any further solution or the above is not a likely scenario, you may try updating the .vstemplate files that use the "$safeprojectname$" parameter with a structiure that removes the extra postfixes. These files are located under "...\Guidance Package\Templates\Projects" and there look for the WCF.vstemplate template and "..\Guidance Package\Templates\Projects\WCFServiceImplementation\ServiceImplementation.csproj" project file. 

There's also a discussion about this topic here: http://social.msdn.microsoft.com/forums/en-US/vsx/thread/e3cff603-16da-462a-a7e8-035b7f2e0062/