msi installer needs elevated privileges to run

Topics: Service Factory Modeling Edition Forum
Sep 27, 2009 at 7:25 AM

I've tried installing the msi file for this, but it keeps failing saying I need to run the installer with elevated privileges.  However, I do not get the run as administrator option with msi files.  I am running Windows 7 as an administrator.  I have tried running it through a command prompt with elevated privileges but that does not appear to work either.  Not sure what is going on here, but it is certainly frustrating as hell.

Bob

Sep 28, 2009 at 1:04 PM

Hi Bob,

The current version of the WSSF installer was not tested against Windows 7 so if all the suggestions for this scenario running on Vista didn't work, then I suspect that you may need to install it on Vista (may be a VPC) until a new version of the installer come out that runs under W7 or we find some workaround for this. 

Sep 30, 2009 at 1:50 AM
Can you point me in the direction of the suggestions for Vista? Maybe I have been looking in the wrong place.

Bob
Sep 30, 2009 at 12:17 PM

You should run the msi under and admin prompt.

You can also read this in case of any further issues.

Sep 30, 2009 at 2:39 PM
Could you describe how to run an msi under an admin prompt? There is no option for run as admin when right clicking on the icon for the installer.

Bob
Sep 30, 2009 at 3:35 PM

You can follow these steps to run the msi under and admin prompt:

  1. In the "Start Search" box type CMD or CMD.EXE
  2. Hit CTRL+SHIFT+ENTER, this key combo triggers user account elevation and is identical to the RUNAS command or the GUI "Run as administrator" option.