Installing Web Service Software Factory - December 2006

Topics: July and December Releases Forum
Jan 31, 2007 at 1:12 PM
I get the error message:

"You must uninstall the July 2006 version of Service Factory before you install this one"

I have run the MSI unintall, and this item no longer apiers in Add/Remove Programs.

What can I do?
Developer
Jan 31, 2007 at 2:34 PM
Make sure that the installation folder does not exists. If that's the case, then use Windows Explorer to remove that folder in Program Files and all of its contents.
Let me know if that did not solve the problem.

Hernan
Feb 19, 2007 at 9:33 AM
I have tried the solution but still get the same error message.
Developer
Feb 19, 2007 at 3:53 PM
Do you have the latest version of GAX/GAT installed? if not, then uninstall your current version and install it from here:
http://msdn2.microsoft.com/en-us/teamsystem/aa718949.aspx

You may also check if you have met all the requirements listed in the documentation under "System Requirements", in particular the one for WCF and .NET 3.0 RTM version.

Charly
Feb 19, 2007 at 6:51 PM
I am having major installation problems. I installed "Web Service Software Factory - December 2006.msi"; at some point I installed "GuidanceAutomationExtensions.msi" and "GuidanceAutomationToolkit.msi", and recently I installed the earlier version of the WSSF (Web Service Software Factory (VB) - July 2006.msi). This did not achieve the desired results and I tried uninstalling/repairing all kinds of combinations of the above packages, but uninstall and repair result in the error message "Item has already been added. Key in dictionary: c:\program files\...\ASMX Client\CLient.vstemplate", key being added (same value). I would be happy uninstalling all of these and starting from scratch, but I get the error above and it will not uninstall.
Is the source code for this project available?
Feb 19, 2007 at 8:06 PM
I solved the problem by running msizip, available by download from Microsoft. The original instructions I found, at http://staff.southworks.net/blogs/mariano/archive/2006/09/06/820.aspx, had a list of files and registry settings to delete, but I think msizip was the only thing I needed.
Feb 20, 2007 at 4:21 AM
I have removed the registry entries of all registered guidance packages as pointed out in tomholl's blog and even uninstalled GAT and GAX. I installed back GAX and GAT; then tried installing service factory Dec 2006 but to no avail.
Feb 20, 2007 at 2:19 PM
I got similar a issue but now it seems to work fine once that I installed the GAX Extension Library ( http://www.codeplex.com/GEL) . I hope it help.
Should it be added to the software requirement list?
Developer
Feb 20, 2007 at 9:35 PM
Juankdiz,

Actually the GAX Extension Library (version 1.1 used by WSSF) is already included in WSSF and as far as I know, it is not used by the installer. However, your scenario might have been different than those described above and the GEL installer may have fixed your prevoius installation with some other setting.
Trying with msizap (cited by stenaught) included in the SDK might be another alternative solution but that depends on the actual cause of your problem.
Feb 26, 2007 at 9:51 PM
Edited Feb 26, 2007 at 10:46 PM
EDIT: Fixed! Had to manually delete windows installer registry keys for product {9F14464B-296E-420A-B41A-D7D3AD4767A8}.


I've the same sort of problem. Nothing in control panel for the July 2006 version. I followed the advice at http://staff.southworks.net/blogs/mariano/archive/2006/09/06/820.aspx and tidied up the file system and reinstalled the latest GAX/GAT packages. But I still can't install.

As I inherited this machine I don't have the original msi package that was used for the July 2006 install. Downloading, installing and uninstalling "Web Service Software Factory (VB) - July 2006 (refresh).msi" didn't help. Nor did running msizap with this package.

Can someone give me the product code to try with msizap? Or a registry key to alter/delete? Or any other advice?

Andy.