Error trying to obtain database metadata information

Topics: Service Factory Modeling Edition Forum
Jan 20, 2009 at 4:20 PM

I am trying to create business entities using repository factory with Oracle as back end. But am getting the "metadata information" error after selecting the connection string. I even changed the provider name to providerName="System.Data.OracleClient" in the connection string. But still no success.

I looked many posts on this. But i did not understand it. But i am wondering if any installer package is released for Oracle connection issue. If anybody knows it, please help me out on this.

If there is no installer package released for this, can anybody please help me to resolve this issue as am not able to go forward?

Jan 20, 2009 at 5:41 PM
You can search for this in the Repository Factory site here:
Jan 20, 2009 at 11:08 PM



Thanks for your reply. Today i have installed the repository factory released on Jul 6th 2008 with Oracle support. But still no success.  But after the the latest installation, then if change the provider name to providerName="System.Data.OracleClient" in the config file, then am not getting the metadata error that i used to get earlier. Now i am not getting any error. But its not showing up any tables/views after selecting the connection. It just shows the connection that i selected and there are no tables/views below to it. As a result i am not able to go ahead and not able to create business entities.

Can anybody Please help me on this.


Jan 21, 2009 at 11:56 PM
I would try searching the Rep.Factory forum, there you will find some posts like these that may help: