Generate code option, not visible for service contract file

Topics: Service Factory Modeling Edition Forum
Apr 2, 2008 at 6:58 AM
While working on service factory - 15 minutes walkthrough (BlueYonderAirlines). Following the steps mentioned in file "15MinuteWalkthrough.pdf", under the section Generate the source code and Run the Service, step 2 "Open the MaterialMgmt.servicecontract file, right click on the design surface, and choose Generate Code".

The issue I am facing is: The Generate Code option is not showing. Please help in resolving the issue.
Apr 2, 2008 at 3:55 PM
Try checking if you already set the technology and project mapptin table properties in the model propertiy window. That's might be the reason why that option doesn't show up.
Apr 3, 2008 at 9:29 AM
Edited Apr 3, 2008 at 9:29 AM
Yes, both the properties implementation technology and project mapping table are set to WCF extensions and BYA.Mfg.SCM respectively.

charlyfriend wrote:
Try checking if you already set the technology and project mapptin table properties in the model propertiy window. That's might be the reason why that option doesn't show up.

Apr 3, 2008 at 6:53 PM
Check if you have the package enabled in VS menu "Tools\Guidance Package Manager..." and "Enable\Disable" button, select package "Service Factory : Modeling Edition".
Apr 4, 2008 at 5:18 AM
The checkbox for all the references (recipes section) are ticked. Which indicates that the packages are enabled. The installation information which I would like to share is as follows:
1. Service Factory: Modeling Edition - version 1.0 (Observed in VS Guidance Navigator)

Information gathered from Add/Remove programs on the click of (Click here for support information)
2. Guidance Automation Extension version 1.0.0.3
3. Microsoft DSL Tools Redistributable - version 1.0.0000
4. Web Service Software Factory: Modeling Edition - version 3.0.0.0
5. MS VS ProjectAggregator2 - version 1.01.61205.56

Does the versions combination correct to make it work?


charlyfriend wrote:
Check if you have the package enabled in VS menu "Tools\Guidance Package Manager..." and "Enable\Disable" button, select package "Service Factory : Modeling Edition".

Apr 4, 2008 at 5:02 PM
The versions are fine.
Do you have VS2005 and Windows Vista?
Apr 15, 2008 at 10:02 AM
I have VS2005 and Windows XP Professional with SP2

charlyfriend wrote:
The versions are fine.
Do you have VS2005 and Windows Vista?

Apr 18, 2008 at 4:59 AM
Any clue on the issue??

samshulie wrote:
I have VS2005 and Windows XP Professional with SP2

charlyfriend wrote:
The versions are fine.
Do you have VS2005 and Windows Vista?


Apr 18, 2008 at 12:58 PM
Edited Apr 18, 2008 at 1:15 PM
How about this:
http://www.codeplex.com/servicefactory/Thread/View.aspx?ThreadId=24910