Missing references with source installer

Topics: Service Factory Modeling Edition Forum
Mar 13, 2008 at 6:31 PM
When following the installation instructions for the service factory: modelling edition for the source code installer, I can get to step 7. Rebuild the entire solution, before running into some 233 errors on the rebuild.


Here are a couple examples:

Error 1 The type or namespace name 'ComponentModel' does not exist in the namespace 'Microsoft.Practices' (are you missing an assembly reference?) C:\Projects\WssfSrc\ServiceFactory.RecipeFramework.Extensions\Source\Editors\ListEditor.cs 28 27 Microsoft.Practices.ServiceFactory.RecipeFramework.Extensions

Error 49 Metadata file 'C:\Projects\WssfSrc\ServiceFactory.RecipeFramework.Extensions\Source\bin\Debug\Microsoft.Practices.ServiceFactory.RecipeFramework.Extensions.dll' could not be found Microsoft.Practices.Modeling.ExtensionProvider


I'm running Windows XP 64bit edition.
Visual studio 2005 version 8.0.50727.762 (SP .050727-7600) - Team Suite
an dI have the prerequisists of
Visual Studio 2005 SDK Version 4.0
Microsoft .NET Framework 3.0
GAX and GAT Feb 2008 editions

Any idea what could be causing this?

Thanks.




Developer
Mar 13, 2008 at 7:27 PM
The WSSF:ME for VS2005 was released for GAX 1.3 so in your source installer you will need to update the references to GAX 1.4 and that should fix the problem.
The fast way is to check those refs that have "warnings" in your Refenreces node and set the "Specific Version" property valye to "false".
Mar 13, 2008 at 8:50 PM
Thanks. That seems to have worked to get rid of the warnings and enable me to finish the install steps
Mar 20, 2008 at 3:19 AM
I had the same issue and I tried the workaround suggested by Charlyfriend which got me a error free build. When when I try to register it I get errors on all recipes along the lines ....createmodelref .... refcreator does not exist and so on for each recipe.