Error when trying start WSSF (source) in Exp. hive

Topics: Service Factory Modeling Edition Forum
Feb 8, 2008 at 8:10 PM
When I tried to launch WSSF (source version) I got the error "The imported project "C:\Program Files (x86)\Microsoft Visual Studion 8\Common7\IDE\PublicAssemblies\Microsoft.Practices.ServiceFactory.Product.targets" was not found. Confirm that the path in the ,Import> declaration is correct, and that the file exists on the disk. C:\WssfSrc\Product Definition\Debugging\Debugging.ssfproduct". I am using Wista x64. I scanned the disk but the file Product.targets was not found. ModelProject project was set as StartUp project. Could someone help me, please?
Feb 8, 2008 at 10:54 PM
Are you using the release version of the factory? We removed the Product.targets file for the VS2005 released version.

Typically the source is not launched in the experimental hive, what are you trying to accomplish by launching the source there?

-b
Feb 9, 2008 at 8:11 AM
I used this link to download the factory: http://www.codeplex.com/servicefactory/Release/ProjectReleases.aspx?ReleaseId=8130. I installed the factory according to Installation Instructions for Source Code Installer. All were alright, no exceptions or error messages.

Actually I'm trying to create a Service Factory: Modeling Edition solution. I use normal (non-experimental) instance of Visual Studio, open the Service Factory Guidance package.sln file from installation folder (C:\WssfSrc), set up ModelProject project as StartUp project, press F5 so the second instance of Visual Studion starts which is trying to load Debugging solution and at this very moment I get the message: "The imported project "C:\Program Files (x86)\Microsoft Visual Studion 8\Common7\IDE\PublicAssemblies\Microsoft.Practices.ServiceFactory.Product.targets" was not found. Confirm that the path in the ,Import> declaration is correct, and that the file exists on the disk. C:\WssfSrc\Product Definition\Debugging\Debugging.ssfproduct".

When I open Debugging.ssfproduct I can see the line "<Import Project="$(SFBasePath)\Microsoft.Practices.ServiceFactory.Product.targets" />" at the end of the file.

So what I did wrong and what I should do?
Feb 11, 2008 at 11:09 AM
On order to create a ME solution with the source code, you first need to build the source sln and register with GAX (Register Package menu option). After that you can open a new solution and create a ME project. The source code solution is to build and register the tool (ME) only.
Feb 11, 2008 at 10:26 PM
AmeriStar,

I think you may have found an out of date remnant that probably should not be out there. Instead of trying to f5 debug into something, I'd recommend creating a new project from within the experimental hive. File|New Project|Guidance Packages|Service Factory: Modeling Edition|Model Project



AmeriStar wrote:
I used this link to download the factory: http://www.codeplex.com/servicefactory/Release/ProjectReleases.aspx?ReleaseId=8130. I installed the factory according to Installation Instructions for Source Code Installer. All were alright, no exceptions or error messages.

Actually I'm trying to create a Service Factory: Modeling Edition solution. I use normal (non-experimental) instance of Visual Studio, open the Service Factory Guidance package.sln file from installation folder (C:\WssfSrc), set up ModelProject project as StartUp project, press F5 so the second instance of Visual Studion starts which is trying to load Debugging solution and at this very moment I get the message: "The imported project "C:\Program Files (x86)\Microsoft Visual Studion 8\Common7\IDE\PublicAssemblies\Microsoft.Practices.ServiceFactory.Product.targets" was not found. Confirm that the path in the ,Import> declaration is correct, and that the file exists on the disk. C:\WssfSrc\Product Definition\Debugging\Debugging.ssfproduct".

When I open Debugging.ssfproduct I can see the line "<Import Project="$(SFBasePath)\Microsoft.Practices.ServiceFactory.Product.targets" />" at the end of the file.

So what I did wrong and what I should do?

Feb 12, 2008 at 8:43 PM
Thank you all. Your answers was very helpful for me. I appreciate this. Thank you.