Web Service Software Factory for Windows 7?

Topics: Service Factory Modeling Edition Forum
Mar 29, 2010 at 8:14 PM

When I attempt to install the Web Service Software Factory on Windows 7, it gives me an error: "This program must be run from an elevated command prompt."  When I go to run as Administrator, it then tells me that: "Windows cannot access the specified drive, file, or path.  You may not have the appropriate permissions"  I install things using my Admin account all the time.  The only thing I can think of, unless there is truly another problem, is that this application doesn't work on Windows 7.  I haven't seen any problems reported anywhere about this issue, though.  Am I correct about the issue?  Is there a workaround?  Thanks.

Sincerely,

Jesse Kircher 

Mar 29, 2010 at 8:25 PM

Oh, and I am using Visual Studio 2008, and installed all of the correct prerequisites.  Thanks.

Developer
Mar 30, 2010 at 10:12 AM

Hi Jesse,

I don;t recall any issue on W7 but you can check the scenarios for Vista. You have the known issues page and other links:

http://servicefactory.codeplex.com/wikipage?title=V3KnownIssues

It's strange that running as admin you have permission error messages. Are you running the msi under an Admin command promt?

 

Mar 30, 2010 at 1:58 PM

How do you start an Admin command prompt?  I was always trying to run it under Run As Different User, and then I would put in my Admin account.  Other apps that take Admin rights work just fine that way.  Thanks.

~Jesse

Developer
Mar 30, 2010 at 4:05 PM

Just type cmd in your Start\Search input and right click the found cmd selecting "Run as adminstrator". Once in the console just run the msi.

Apr 4, 2010 at 11:29 AM
Edited Apr 4, 2010 at 11:29 AM

Jess10K, Could You tell me if You found solution for the problem ? I had familiar problem on Vista. When I try to install WSSF either appears "This program must be run from an elevated command prompt." or smth like "this is not a valid win32 application".

Cheers

Apr 9, 2010 at 2:18 PM

I did happen to find a solution: go to your Command Prompt in the Accessories menu. Right Click on it and select "Run As Administrator".  Manoever to your directory where you are keeping the MSI on the command prompt, and execute it.  It works just like that.  :-)  Best of luck.

 

Sincerely,

Jesse

Apr 10, 2010 at 1:26 PM
Edited Apr 10, 2010 at 1:27 PM

Already tried this but nope. Anyway thanks for reply :)

Developer
Apr 13, 2010 at 10:27 PM

Did you try it this on Vista? Still the same error whrn running under an admin cmd promt?