Dialog disappears when selecting an XSD Element

Topics: Service Factory Modeling Edition Forum
Dec 27, 2007 at 9:20 PM
I have tried creating my own project with the modeling edition. However, when I get to the part where I add an XSD file to the project and select an element, I can browse to the XSD Element in the Solution tree, but when I select it, the dialog goes poof and nothing happens. No element reference appears in the "Element" object property. The namespaces seem okay (but I don't know what the rules are beyond just copying the hands-on Blue Yonder lab). The schema is almost exactly like the example. I just don't know what it means when I click on an element and the dialog goes away without letting me click OK and accepting it.

By the way, the Blue Yonder lab example DOES let me select, so I know I'm going wrong, but I have no idea how to interpret this behavior.


Dec 28, 2007 at 2:56 AM
It seems that the schema has someting that might get the picker to throw an exception and that may cause the dialog go away. You can try zip the solution and send it to me (start contacting me using my alias in this list and I will write you back the instructions.

Jan 4, 2008 at 1:54 PM

Thanks for the response. For the fun of it, I added the BlueYonder XSD to the project and tried adding it with the same poof response.

So I don't think it's anything in the schema unless maybe it's a namespace clash. I'm not sure I get how the WSSF expects the XML namespaces to be setup so that it can be included. I have a sneaky suspicion that it is something that I don't understand that's biting me, and that's where namespaces rear their ugly heads.

Jan 4, 2008 at 3:40 PM
Nevertheless, you may send me out the xsd in odert to investigate and try getting a better error message to give som hint about the cause.

Feb 5, 2008 at 6:44 PM
I ran into the same problem. For whatever reason, my XSD file ended up in the "Solution Items" folder rather than the "Schemas" folder. I believe this is what causes the problem. I moved my XSD to the Schemas folder and it fixed the problem.