Want - December 2006 release

Topics: General Discussion Forum, July and December Releases Forum
Dec 20, 2007 at 9:45 AM
Hello

i want to download december 2006 release of the web service software factory.
and i cant find it
please can someone tell me where can i download from

Arun
Developer
Dec 20, 2007 at 10:28 AM
Not sure why do you want the "old" version of the factory that in turn will need the appropiate GAX/GAT versions (not the current one).
The public link should be here but I think it was removed. Let me know if you can't use the latest version and I will investigate if there is still the previous version arround.
Jan 4, 2008 at 9:06 AM
Edited Jan 4, 2008 at 9:23 AM
I am building a custom WCF guidance package.
i have some experience customising the ASMX version before and i want to use the same skills
Arun
Jan 4, 2008 at 11:45 AM
The "Old" version of the factory also has support for WSDL first service creation, which was to my best knowledge not implemented in the current release. I have created projects with the "Old" version and now others must colaborate on these. It seems to me quite drastic to virtually erase all traces from codeplex.
Jan 4, 2008 at 12:16 PM
Thanks i got it .
Jan 7, 2008 at 6:33 AM


agopalam wrote:
Thanks i got it .


From where? I want that too plz...
Jan 7, 2008 at 6:48 AM

tomastomasson wrote:
It seems to me quite drastic to virtually erase all traces from codeplex.


Exactly my point - but until now noone seems to agree with that politic.
There are several reasons why the old factoring must be accessible.

--
Coordinator
Jan 7, 2008 at 9:47 PM
Hey everyone,

I appreciate all of the feedback and I hear you loud and clear. I apologize for not seeing this need ahead of time. I just posted the December release here. Please read the text associated with the release. Thanks again,

Don
Jan 10, 2008 at 3:38 PM
Don, I am trying to uninstall the December 2006 version, but am having a problem on the MSI uninstall. I am looking for the original install and proceeded to your link above. This is not allowing a repair though as that the routine for repairing it says that it is not the original MSI. Was there a December Refresh that you could make available (that is what the repair routine is referencing in the error msg)? I think that I need this in order to remove the 2006 guidance package. This is keeping me from installing the latest package that I want/need to explore for potential use in a project. Any assistance would be appreciated.

Thanks!
Developer
Jan 10, 2008 at 5:19 PM
If you want to uninstall without waiting for a new msi, you can follow the steps detailed here:
http://www.codeplex.com/smartclient/Thread/View.aspx?ThreadId=8562.
You can try with step 3 and remove the WSSF package. Then uninstall GAT, GAX and reinstall the latest WSSF along with all the requirements.
Jan 13, 2008 at 7:12 PM
Edited Jan 13, 2008 at 7:12 PM
Thanks Don.
Jan 14, 2008 at 11:18 AM
I cant install WSSF december 2006 release because I dont have GAX June 2006.... where can I get the GAX and GAT that is needed to install WSSF december 2006 release?

Please help!!!
Coordinator
Jan 14, 2008 at 5:40 PM
RightCoder, you are having essentially the same issue as Swannie. The Dec 2006 release I've made available isn't the "refreshed" one so it is REQUIRING a specific version of GAX. I'm trying to track down the refreshed build now and will post it as soon as I can. I'm sorry about all the confusion. I totally forgot about the refresh.
Jan 14, 2008 at 9:10 PM
What version is the refreshed build?
"Web Service Software Factory - December 2006 (refresh).msi"?
I have it if you need it... let me know.
Jan 15, 2008 at 12:04 PM
tomastomasson, I really need it so if you could make it available for me it would be great. Or I wait for Don to finish his work. Thanks both of you!

RightCoder

Jan 15, 2008 at 10:10 PM
Don, tomas sent me a version of the refresh-version but it didn't install because it needed the 1.1 version of GAX. I dont have that and I'm not able to get it either. I thought this refresh version would install on newer versions of GAX and GAT but it seems not to do that or do you have another version of this refresh version? Or could anyone tell me where I could find older versions of GAX and GAT?

RightCoder
Jan 16, 2008 at 10:21 AM
Now it works fine!! My friend from Iceland, Tomas, helped me with the old versions and it now works fine. Installing the refresh version with old GAX/GAT (version 1.1) worked quite well. Don, it would be nice if old versions and their requirements are available in the future, they will always be needed by someone sometime.

Now both Tomas and I have GAX/GAT/WSSF v2 that works together and we will help if someone need the files.

RightCoder.
Coordinator
Jan 17, 2008 at 3:04 AM
Thanks RightCoder. I've also just updated the v2 download so it is the refreshed version. This should install on the new versions of GAX ... that was the whole purpose of the refresh. I'm not sure why you needed 1.1, but I'm glad you're all set now.