I don't seem to have the menu options

Topics: General Discussion Forum, Service Factory Modeling Edition Forum
Nov 28, 2007 at 5:32 PM
I am very new to the web service software factory and can get it installed ok, or so i thought. However, when i go to start a new project, I do not have the same options as in the demos from the videos but i thought that was ok because maybe they were not using the 'modeling edition' but then they have things like "Unlock Solution" when they right click on the solution, and "Specify Project Responsibility" under "service Factory (WCF)" when right clicking on a service contract and i do not have those.

I am running under VS2005 Pro in XP Pro SP2

I installed the Toolkit and the extensions. I have the VS2005 SDK Feb 2007 installed as well.

Is this normal or is there something that is still missing from my setup.

The video that I refer to is the
"27 Mar 2007: Don creates some service interfaces with the WCF Service Factory. Interested in performing this demo yourself?"

Please excuse me if I have forgot to mention something important as like I said before, I have not been working with this for very long.
Nov 28, 2007 at 6:07 PM
By your description, you've installed the December 2006 version (v2) of the WSSF.
I suggest you to download the latest version, the Modeling Edition from the launching page here http://msdn2.microsoft.com/en-us/library/bb931187.aspx.
Nov 28, 2007 at 6:11 PM
The MSI that i installed from has a date of 10/31/2007 3.02 AM. This is the location that I originally got the files from.

The installer also says Modeling Edition. I have downloaded the zip from that link and compared it and it is the same file.
Nov 28, 2007 at 6:32 PM
It looks like you have WSSF v2 and v3 installed on your machine. If so, you should disable the WSSF v2 Guidance Package using the Guidance Package Manager.

Please let me know if this helped.
Nov 28, 2007 at 7:33 PM
While I am pretty sure that is not the case, I did uninstall the v3 and then tried to open a project created by WSSF and it says "Make sure the application for the project type (.ssfproduct) is installed."
The project I tried to open was the 15 minute demo project

I just installed stuff yesterday and my machine was staged on the 16th of this month. Can you even still download the v2 of the WSSF? you think if I uninstall my v3, then install v2 and do an uninstall of v2 that it would clean things up?

Also, I have VS2008 90-day trial on here with .Net 3.5. You think that could be causing issues?

Where does WSSF v2 install by default? i have a "C:\Program Files\Microsoft Service Factory V3" folder but no other service factory folders.

Sorry to be causing so much confusion (mostly on my part) and seeming like a total newb (which i am, heh)
Thanks for all your help and input so far, I would be TOTAL:LY lost without this place.
Nov 28, 2007 at 7:41 PM
Currently WSSF V3 is not supporting VS 2008 (beta or release versions). It supports Microsoft Visual Studio 2005 (Visual Studio Professional Edition or Visual Studio Team Suite), here's the link to the MSDN Launch page where you can find all the requirements for V3. http://msdn2.microsoft.com/en-us/library/bb931187.aspx

I hope this helps, cheers.
Nov 28, 2007 at 7:54 PM
Yes, I am using it in VS2005. I was just stating that I had VS2008 installed. I didnt know if perhaps there were known issues with installing WSSF on a machine with both VS2005 and VS2008.

I am using VS2005 Pro to run things though.
Nov 28, 2007 at 9:02 PM
So your scenario is this:
You have v3 and v2 installed. That's fine because they should run smoothly side by side. The thing here is that you got the v2 guidance package enabled and that's why you got the recipes from v2. Now you need to go and disable v2 package from your solution and enable v3 package named as "Service Factory: Modeling Edition" in the Guidance Package Manager in VS Tools option.
So if you uninstalled v3, then simply go an re-install it and follow the steps above and you should be fine.

Nov 28, 2007 at 9:07 PM
Ahh, i see. Thanks. That was confusing. I did download the december release at one point or another.

Now that I have the v3 installed and Modeling guidance package enabled, should I be able to right click on the solution and select "Unlock Solution"? or was that just part of the v2 edition?
Nov 28, 2007 at 9:13 PM
That's part of V2. Make sure you disabled all the V2 Guidance Package features using the Guidance Package Manager. It seems you have a mix of them :)
Nov 28, 2007 at 9:25 PM
yes, I am not able to do that with the v3 package enabled. it would see that everything is all set to the v3 version now.

I know (or thought) that I read somewhere that they were going to be going through a demo, like they did with v2, for the new Modeling edition, is this true? and is there an ETA, or am I just having a small case of wishful thinking?
Nov 28, 2007 at 9:27 PM
Ahh, i just read it again and the link to the video section specifically says "(not yet updated for the modeling edition)"

haha. I will just have to keep my eyes open for that to come.

Once again, thanks all of you for helping me clear things up. I only hope that I soon will be able to contribute to others as you have contributed to me today.