Host Model Menu Items Not Appearing

Topics: Service Factory Modeling Edition Forum
Nov 20, 2007 at 9:42 PM
Hello.

We've installed the Service Factory on several developers' machines, and on all but one of the machines the context menu that pops up when right-clicking on items in the host model is only displaying the "Validate" and "Validate All" items and is missing the "Add ..." items. The only machine that shows the menu items is one that has Team Suite installed. The others have Develper and Enterprise Architect editions installed. Maybe that's just coincidence.

It seems that those "Add ..." menu items are autmatically created by DSL Tools. How do we get those to show up?

Thanks.
-andy


Nov 20, 2007 at 11:46 PM
Have you tried running DEVENV /SETUP ?

This may fix your problem. Are you running Vista or XP?

Ade
Nov 21, 2007 at 2:57 PM
Hi Ade

Yeah, DEVENV /SETUP has no effect on the issue. All our machines are running on XP SP 2. Some have VS SDK July installed some don't. We've tried all the uninstall/reinstall options we could think of.

The real weird thing is that the "Add ..." items show up on the other DSL explorers in the Factory...just not the Host Model Explorer.

I had another developer install it last night on a Teams System Developer Edition box and that one worked as expected. I'm stumped.

-andy
Nov 28, 2007 at 4:55 AM
Hi

I got same problem as well and stuck now.
I install everything and my visual studio is Team Edition for Developer. I doubt if it is caused by installing DotNet Frame 3.5. One of my colleagues install .net 3.5, it seems his application was killed by new .net.

wait for somebody give answer.

- wei
Nov 28, 2007 at 2:27 PM
Wei,

I'm not sure about the "effects" of NET 3.5 since WSSF v3 was tested and developed with NET 3.0. I;ll go back to this thread as soon as I can get some testing regarding this issue.

Thanks,
CF
Nov 29, 2007 at 12:42 AM
CF,

Thanks, I already tried uninstall Net 3.5, and all the guidance automaction application. Reinstall from .net 1.1, 2.0, 3.0 and WSSF.
I still can not see the Adding menu in Host Model.
I also tried install the source code and want to step into actions, but it turned out to be a disaster to vs2005(The WSSF seems too complicated). Is any architecture help us modify the source code and have an idea what heppend to this.

cheers

wei
Nov 29, 2007 at 10:22 AM
The upcoming Extensibility Hands-on lab will show you how to modify the source code of WSSF. And on the other hand, beware of installing the sourcode along with the binary. The documentation describe the appropiate steps to do this.
Regarding your issue, Did you install Vs2008? I know there are some issues here.
The compatible version for 2008 is not ready yet.
Nov 30, 2007 at 3:13 AM
Thanks CF:

I haven't installed vs2008 yet in my machine. But In my develop machines I installed all the previous versions before and uninstall thme now. I am not sure if that cause problem.
Yesterday, I installed WSSF in my new laptop. It seems worked in laptop.
Hope the upcoming extensibility Hnads-on lab come soon

wei
Dec 5, 2007 at 5:34 PM
It looks like the DSL Tools has responsibility for displaying those menu items. DSL Tools displays those “Add…” items by default for any DSL your create and view the domain explorer for. I tried weeding through the DSL Tools generated code for the Explorer to see if I could find out where exactly those items get added to the menu, but I got lost and hung it up.

If it helps, here's the machines we have and only two of them are working. As you can see the configurations are all over the map so I don’t know if this will help much.

Configs that ARE displaying the "Add ..." items in host designer

Machine #1
Windows XP
Windows SDK
VS 2005 Team Suite
VS 2005 SDK (February 2007)
VS 2008 Team Suite
VS 2008 SDK (November 2007)
GAX July 2007
DSL Tools Redistributable
ProjectAggregater2
Both binary install and source installs of Service Factory have worked.
.Net 2.0 (SP 1), 3.0 (SP 1), 3.5

Machine #2
Windows XP
VS 2005 Team System Developer
VS 2005 SDK (February 2007)
VS 2005 Premier Partner Edition
GAX July 2007
Binary install of Service Factory
.Net 1.1, 2.0, 3.0

Configs that ARE NOT displaying the "Add ..." items in host designer

Machine #3
Windows XP
VS 2005 Team System Developer
VS 2005 Team System Tester
VS 2005 SDK (February 2007)
VS 2008 Team System Developer
GAX July 2007
DSL Tools Redistributable
ProjectAggregator2
Binary install of Service Factory
.Net 1.1, 2.0 (SP 1), 3.0 (SP 1), 3.5

Machine #4
Windows XP
VS 2005 Team System Developer
VS 2005 SDK (February 2007)
VS 2005 SDK (September 2006)
GAX July 2007
DSL Tools Redistributable
ProjectAggregator2
Binary install of Service Factory
.Net 1.1, 2.0 (SP 1), 3.0 (SP 1)

Machine #5
Windows XP
VS 2005 Team System Architect
VS 2005 Team Suite
VS 2005 SDK (February 2007)
VS 2005 SDK (September 2006)
VS 2008 Team System Developer
GAX July 2007
Windows SDK for VS 2008
DSL Tools Redistributable, ProjectAggregator2
Binary install of Service Factory
.Net 1.1, 2.0 (SP 1), 3.0 (SP 1), 3.5
Dec 7, 2007 at 12:43 PM
Hi,

I'm also stuck with this issue, any suggestions?

regards
Dec 7, 2007 at 2:44 PM
If someone can't get see the menu items and worse comes to worse I suppose they could edit the xml in the host file by hand using one of the host files from the walk-throughs as the starting point. I haven't tried it, so I don't know if it will work or not.
-andy
Dec 7, 2007 at 4:28 PM
Andy,

Your suggested workarround is valid and you may add the <applicationHost> element to the host file (opening with XML Editor) and the rest of the section may be added on the designer since the only missing "Add.." menus are the ones from the root (HostApplication and ClientApplication).
So adding something like this will solve the Add (Host in this case) issue.

<hostApplication name="MyNewHostApplication" 
      implementationProject="[Path to your host project] 
      implementationTechnology="{44e8a8c3-3651-4932-bae3-1faf3684e2f3}|WCF|WCF Extensions">
</hostApplication>
You can do the same with the clientApplication and also change the implementationTechnology as well (For ASMX, {ff107115-d18b-4f82-9b82-d6f8c77b8693}|ASMX|ASMX Extensions)
Feb 4, 2008 at 4:37 PM
Charlyfriend,

If I follow your surgested workarround I can manually create host- (and client) applications in the xml, but after this, the next step: adding Service References also has to be done manually. Looking at the code after Ex 7 shows that this demands manually adding sections like this:


<serviceDescriptions>
<serviceReference objectExtenderContainer="AAEAAAD/////AQAAAAAAAAAMAgAAAGZNaWNyb3NvZnQuUHJhY3RpY2VzLk1vZGVsaW5nLkNvbW1vbiwgVmVyc2lvbj0xLjAuMC4wLCBDdWx0dXJlPW5ldXRyYWwsIFB1YmxpY0tleVRva2VuPTMxYmYzODU2YWQzNjRlMzUFAQAAAFBNaWNyb3NvZnQuUHJhY3RpY2VzLk1vZGVsaW5nLkV4dGVuc2lvblByb3ZpZGVyLkV4dGVuc2lvbi5PYmplY3RFeHRlbmRlckNvbnRhaW5lcgEAAAAPb2JqZWN0RXh0ZW5kZXJzAxxTeXN0ZW0uQ29sbGVjdGlvbnMuQXJyYXlMaXN0AgAAAAkDAAAABAMAAAAcU3lzdGVtLkNvbGxlY3Rpb25zLkFycmF5TGlzdAMAAAAGX2l0ZW1zBV9zaXplCF92ZXJzaW9uBQAACAgJBAAAAAEAAAABAAAAEAQAAAAEAAAACQUAAAANAwwGAAAAgAFNaWNyb3NvZnQuUHJhY3RpY2VzLlNlcnZpY2VGYWN0b3J5LkV4dGVuZGVycy5Ib3N0RGVzaWduZXIuV2NmLCBWZXJzaW9uPTEuMC4wLjAsIEN1bHR1cmU9bmV1dHJhbCwgUHVibGljS2V5VG9rZW49MzFiZjM4NTZhZDM2NGUzNQUFAAAAU01pY3Jvc29mdC5QcmFjdGljZXMuU2VydmljZUZhY3RvcnkuRXh0ZW5kZXJzLkhvc3REZXNpZ25lci5XY2YuV2NmU2VydmljZURlc2NyaXB0aW9uAQAAABhlbmFibGVNZXRhZGF0YVB1Ymxpc2hpbmcAAQYAAAABCw==" name="MaterialMgmt" serviceImplementationType="Microsoft.Practices.ServiceFactory.ServiceContracts\Service\PartsMgmtService@BlueYonderAirlines\MaterialMgmt">
<endpoints>
<endpoint Id="67e7959b-e861-43e9-be3f-e8417cbd6039" objectExtenderContainer="AAEAAAD/////AQAAAAAAAAAMAgAAAGZNaWNyb3NvZnQuUHJhY3RpY2VzLk1vZGVsaW5nLkNvbW1vbiwgVmVyc2lvbj0xLjAuMC4wLCBDdWx0dXJlPW5ldXRyYWwsIFB1YmxpY0tleVRva2VuPTMxYmYzODU2YWQzNjRlMzUFAQAAAFBNaWNyb3NvZnQuUHJhY3RpY2VzLk1vZGVsaW5nLkV4dGVuc2lvblByb3ZpZGVyLkV4dGVuc2lvbi5PYmplY3RFeHRlbmRlckNvbnRhaW5lcgEAAAAPb2JqZWN0RXh0ZW5kZXJzAxxTeXN0ZW0uQ29sbGVjdGlvbnMuQXJyYXlMaXN0AgAAAAkDAAAABAMAAAAcU3lzdGVtLkNvbGxlY3Rpb25zLkFycmF5TGlzdAMAAAAGX2l0ZW1zBV9zaXplCF92ZXJzaW9uBQAACAgJBAAAAAEAAAABAAAAEAQAAAAEAAAACQUAAAANAwwGAAAAgAFNaWNyb3NvZnQuUHJhY3RpY2VzLlNlcnZpY2VGYWN0b3J5LkV4dGVuZGVycy5Ib3N0RGVzaWduZXIuV2NmLCBWZXJzaW9uPTEuMC4wLjAsIEN1bHR1cmU9bmV1dHJhbCwgUHVibGljS2V5VG9rZW49MzFiZjM4NTZhZDM2NGUzNQUFAAAASU1pY3Jvc29mdC5QcmFjdGljZXMuU2VydmljZUZhY3RvcnkuRXh0ZW5kZXJzLkhvc3REZXNpZ25lci5XY2YuV2NmRW5kcG9pbnQBAAAAC2JpbmRpbmdUeXBlBElNaWNyb3NvZnQuUHJhY3RpY2VzLlNlcnZpY2VGYWN0b3J5LkV4dGVuZGVycy5Ib3N0RGVzaWduZXIuV2NmLkJpbmRpbmdUeXBlBgAAAAYAAAAF+f///0lNaWNyb3NvZnQuUHJhY3RpY2VzLlNlcnZpY2VGYWN0b3J5LkV4dGVuZGVycy5Ib3N0RGVzaWduZXIuV2NmLkJpbmRpbmdUeXBlAQAAAAd2YWx1ZV9fAAgGAAAAAAAAAAs=" name="DefaultEndpoint" />
</endpoints>
</serviceReference>
</serviceDescriptions>


I think I'll be introuble finding these values in a real (no lab) situation. Can you help me out here?

Even better, what can I do to make the Host Explorer work as expected?

Michael
Feb 4, 2008 at 7:11 PM
I think that your best bet may be re installing the WSSF in a clean machine with all the requirements. If that's no possible, then try reseting the
experimental hive and reinstall WSSF, GAX and VS-SDK (all reqs but VS).





Feb 6, 2008 at 1:23 AM
You can find more discussion about this issue here: Host Explorer.
Apr 28, 2008 at 8:58 PM
I'm just chiming in to say that I'm having the same problem.
Everything else with the other models seems to be working.
Just in Host Explorer I do not get the context menu's such as "Add New Host Application"...

My setup details:
VS2005 (Team Ed for SW Dev) only
Binary install of WSSF-ME

Any resolution out there?
Thanks.
Apr 29, 2008 at 2:45 PM
mdtiki,

Did you take a look at this thread http://www.codeplex.com/servicefactory/WorkItem/View.aspx?WorkItemId=4459 in particular this post:

_Correction: this appears to be a UI design problem.
I found the right-click option on the Host Model in the Host Explorer where I could add client and host applications and successfully added them.
I had expected that I could have found that method as an obvious option in the Host Model main form (when the host was opened in Solution Explorer).
I had also expected that the option would have been available from the solution explorer when I right clicked on xxxxx.host.
I had also expected that it would have been available from right click on the folder "Client Applications" folder or "Host Applications" folder in the Host Explorer._

And this:

_I don't have the sevice factory installed at home but from memory I think you need to right-click on the "Host Applications" tree node rather than the root node.
This isn't a bug really. We get this from the DSL model explorer, it's the default behavior. _
Apr 29, 2008 at 8:08 PM
Thanks for the suggestions.
I have looked through both this thread (18103) and that work item thread (4459).
Nothing so far has appeared to offer a resolution.

It just seems that the Host Explorer window is missing all the "Add xxxx" context menu items.

Right clicking the root ("Host Model") node just brings up:
Properties
----------
Validate
Validate All

Right clicking the "Client Applications" or "Host Applications" node just brings up:
Delete All
----------
Validate All

Data Contract Explorer and Service Contract Explorer both seem to work fine. They both have the appropriate "Add New xxxx" context menu items when you right click the root node in their respective windows.
I guess whatever clues the DSL model explorer in to add the context menu items is not working for some reason.

As a possible workaround I was able to copy segments of xml representing the Host Application and the Client Application into my xxxx.host file. Then edit the properties and seemingly get it to work.
Not sure if I'm missing anything but so far it seems to be working.

I would prefer to get the Host Explorer fully functional so any further advice or suggestions would be very appreciated...

Thanks.
Apr 30, 2008 at 7:50 AM
Hi there.

Reinstalling VS2005 and then installing WSSF have worked for me on several machines now.

Michael Brandt Lassen
Denmark
Apr 30, 2008 at 3:08 PM
Thanks for the reply.
I've been trying to avoid the extreme possible solutions, such as reinstall X, and reinstall Y, but at this point that appears to be my only candidate for fixing.
Having said that since this is my primary dev machine I can't see reinstalling VS2005, then what amounts to installing again to apply SP1, then if necessary all the other tools, add-ons, sdks, etc.
just to fix the Host Explorer issue.
If I have time I may delve into the DSL stuff to see how it works and maybe figure out what is going on.
Otherwise if my workaround is adequate I'll stick with that for now.

If anyone has further insights feel free to chime in...

Thanks.
Apr 30, 2008 at 7:16 PM
In your case, another option might be to install this env in a VPC/VM with your same OS and VS2005 or better yet VS2008 with Feb2008 version of WSSF.
May 1, 2008 at 2:54 PM
Thanks again.
Yeah setting up a VPC/VM environment is probably good advice and widely applicable when working with relatively new technology like this.
Any recommendations of what's worked for people in the VPC/VM space?

Also I guess we are getting away from what my initial problem was with regards to the Host Explorer, but it's all good.

Thanks.
May 2, 2008 at 11:20 AM
A configuration like I suggested in my last post should work fine.