Error :when Generating Code of MaterialMgmt Service Reference

Topics: Service Factory Modeling Edition Forum
Nov 13, 2007 at 12:57 PM
Error 2 The argument docData must implement the interface IVsTextStream. who know what happen?
vs :vs2005ts
os:windows 2003
Nov 14, 2007 at 2:25 AM
I've not seen an error like this before. You'll have to provide further information about what you were doing when you got it.

Let us know and we'll try and help.

Nov 14, 2007 at 5:24 AM
I'm at bottom of Page 3 of 15MinuteWalkthrough.pdf,when i generated the source code of MaterialMgmt Service Reference ,this error happens
vs :vs2005ts
os:windows 2003
Nov 15, 2007 at 3:48 PM
Sorry. This still has me stumped. Do you have a call stack you could send me? I'm assuming that the error your seeing appears as an exception dialog but it would really help to know where you see it and what got called.

Any other information would also be helpful. For example is your project/solution bound to a source code control system like TFS? My guess is the factory code gen is trying to save something to a document when this happens.


Nov 19, 2007 at 12:34 PM
Edited Nov 19, 2007 at 12:49 PM

There is no more information about this error .I just click the "Generate Code " link on the page of MaterialMgmt Service Reference ,then this error happens. I try to reinstall this factory,but it's nothing.

Thanks again .

Nov 19, 2007 at 10:47 PM
I also tried to repro on a similar environment (Vs2005+W2003) but had no luck (everything went as expected).
Can you send me you solution that you had completed so far in order to repro the issue or at least cross check if everything is as expected according to the walkthrough doc?

Nov 20, 2007 at 12:28 PM
Edited Nov 20, 2007 at 12:28 PM
Following the steps of the walkthrough doc, I tried to do again and the same error happened again.Could you tell me your email address ,charlyfriend?


Nov 20, 2007 at 1:03 PM
Just send me an email to support AT digitfactory DOT net with the attached sln and I'll investigate your issue.

Jan 22, 2008 at 8:12 AM
Edited Jan 22, 2008 at 8:12 AM
Any updates on this one? I also run into this error when trying the generate a host for a service.


Jan 22, 2008 at 4:38 PM
This seems to be an error with DSL. Try reinstalling following the steps in the installation doc.
Aug 29, 2008 at 12:05 AM
Hi Everyone
I see no solution - error disappears after fiddling with WSSF? huh? :)
It happens when you do have opened web.config of host application (in my case with EntLib Configuration Tool)
Best Regards
Big Up!
Sep 16, 2008 at 3:27 PM
Hi Everyone,
Was there ever a solution posted to this problem?  I just received the same error when clicking the Generate Proxy link on the Host page.

Sep 16, 2008 at 4:49 PM
Hi Everyone,

Never mind.  I just rebuilt it and didn't get the error this time.  I must have done something different but I'm not sure what it was.