Error Installing

Topics: Service Factory Modeling Edition Forum
Nov 9, 2007 at 8:08 PM
I'm trying to install the Binary Installer by following the instructions in the InstallationInstructions.pdf. I meet the first three prerequisites (Windows XP, Visual Studio 2005, .NET 3.0) but I wasn't sure if the GAX version I have (1.0.51104) was the July 2006 CTP.

I tried uninstalling it so I could install the most recent version but get the error message:

The uninstallation of the Guidance Automation Runtime cannot be done. You must first uninstall the following guidance package(s): ASMXGuidancePackage, WCFGuidancePackage, DataAccessGuidancePackage, WCFSecurityGuidancePackage, StrongNamingGuidancePackage, GuidanceBlockFactory, WebClientFactoryPackage

When I try to uninstall " Web Client Software Factory - Januaury 2007" and "Web Service Software Factory - December 2006" or install "Service Factory Binary Installer.msi", I get the following:

Unable to get installer types in the C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies\Microsoft.Practices.ServiceFactory.GuidancePackage.Installer.dll assembly. --> Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

I suspect that my registry is hosed and there's no chance of recovery but I've seen other folks succsssfully install after seeing similar messages.

- John
Nov 9, 2007 at 9:34 PM
I've seen this before. It's typically because the Installer DLL has the following dependencies:


These should bth be in PublicAssemblies and are installed by GAX 1.3 (July 2007)

Let me know if this doesn't fix your problem.

Nov 12, 2007 at 12:59 AM
I ran into a similar issue when uninstalling GAX and found this helpful:

Nov 14, 2007 at 9:53 AM
Edited Nov 14, 2007 at 9:54 AM
That last one did the trick for me, just removing the ones I couldn't find any uninstallers for. The link seems to have been updated to
Nov 14, 2007 at 12:51 PM
That did the trick for me as well. I removed the entries from that file and I was able to uninstall and reinstall just fine.
Jan 10, 2008 at 8:52 PM
Sorry, it didn't work forme, I stillgetting the same error after installing the web client factory

jhurrel, which file you are talking about? please explain
Any other ideas
Jan 11, 2008 at 4:23 PM
You may try this post and check step #3 or the rest if you need more advanced help for removing GAX/GAT and the rest of the packages.
This is specific for Smart Client but you can follow the same steps for other factories as well.