Can't run the Expose Service recipe?

Topics: General Discussion Forum, July and December Releases Forum
Aug 15, 2007 at 10:28 PM
Hello,

I am running WSSF project and I am having a hard time running the Expose Service recipe on my host project?
I have the WSSF (ASMX) enabled in the Guidance Package Manager for that project, but when I right click the host project I don't see the recipe.

Am I missing a config entry?

Best Regards,
Aug 16, 2007 at 8:33 AM
On the Host Project, did you use Specify Project Responsibility to check the Host Project option?
Aug 16, 2007 at 4:14 PM
Edited Aug 16, 2007 at 4:15 PM
Thanks for the reply.

I don't have the option when I right click the project. In fact I don't have any Service Factory options for the project. This leads me to believe I am perhaps missing something in a config file somewhere? Any other ideas?

Aug 16, 2007 at 8:45 PM
I ended up getting this working.

What I failed to mention above was that I was trying to combine the WCSF and the WSSF into one solution. The problem was that I did not have the following in my sln file.

IsSolution = True
ServiceContractNamespace = http://Foo.ServiceContracts/2007/08

See this doc for more info...

http://www.codeplex.com/websf/Wiki/View.aspx?title=Creating%20the%20reference%20implementation%20using%20WCSF%20and%20WSSF