problem if create a new service solutions

Topics: General Discussion Forum
Jun 2, 2007 at 3:30 PM
hallo,

i have install the version b71, execute the msbuild postinstall, gegestry file an register the package.
truble i have at tow points:
1.) build solution
i build the solution at visual studio with the release option and output this error message, bur i dont anderstand it.

Fehler 2 Can't start preprocessor (2) C:\VSProjects\WssfV3Src\Data Contract DSL\DslPackage\CTC DataContractDslPackage
Fehler 3 Can't start preprocessor (2) C:\VSProjects\WssfV3Src\Data Contract DSL\DslPackage\CTC DataContractDslPackage
Fehler 4 Can't start preprocessor (2) C:\VSProjects\WssfV3Src\Service Contract DSL\DslPackage\CTC ServiceContractDslPackage
Fehler 5 Can't start preprocessor (2) C:\VSProjects\WssfV3Src\Service Contract DSL\DslPackage\CTC ServiceContractDslPackage

2.) create a new service solution withe the registrered service package
After the wizard for the solution name and module name, i have this error from the visual studio template assistent:

"can not create the project $ModelProjectName$. The application for ...\Service1.Model.ssfprouct are not installd. install the application for the *.ssfproduct projecttype"

Plase, wahts the Application for *.ssfproduct? I have execute the regestry file an check it at regestry. all entries exists.

Thanks for help.

Marek from Cologne, germany
Jun 4, 2007 at 7:59 PM
Marek,

These two points are likely related, since if the models do not compile correctly the custom project file won't be propertly created. Can you tell me if you have C++ installed in Visual Stuido? This has the required tools to compile ctc files.

-b
Jun 4, 2007 at 10:46 PM
Hallo,

thanks for your help. Your tip fix my problem no. 1.
But have you a ideea for the second, *.ssfproduct ?

Marek from Cologne, germany
Jun 5, 2007 at 4:24 PM
The .ssfproduct project type is the custom project type WSSF uses to store models. Typically you see this error if the package containing the custom project didn't get registered correctly. Have you tried "Rebuild Solution" after fixing your other problem. This should force the solution to (re)register the project.

Ade
Jun 8, 2007 at 9:06 AM
Hallo Ade,

i have rebuild the solution without error message, unregister an register the package... but the same problem.
if i register the package, i receive a schema validation error popup. after ignorre the warning, the regestration are sucsessfull.

Marek from Cologne, germany
Jun 12, 2007 at 2:34 AM
Marek,

What does the schema validation popup say? I'm not sure I've ever seen this. After you ignore it does everythign work correctly? Can you go through the walkthrough for example?

Ade
Jun 12, 2007 at 10:45 AM
Hallo Ade,

the popup say only message "validation faild". I have install the Clarius Software Factory Toolkit and enable the manifest validation option in the Calrius Section under the Visual Studio Otptin.
How can i manual install the components for the *.ssfproduct? Is this a part from a DSL GUI?

Marek
Jun 12, 2007 at 10:07 PM
Marek,

This may be a bug. If you turn Manifest validation off does everything work as expected? I'll try and repro this here.

Ade
Jun 13, 2007 at 5:37 AM
Marek,

I see the same issue here. I've filed a bug on this. I see two errors in the Error List related to validation. I think you can safely ignore these.

Ade
Jun 13, 2007 at 11:24 PM
This will be fixed in the next drop.

Ade
Jun 15, 2007 at 10:31 AM
Hi,
When I create a new service solution with the registered package I get the same error message:
'The application for project ..\Services2.Model.ssfproduct is not installed.'
'Make sure the application for product type (.ssfproduct) is installed'.
Thanks for any help.
Erwin