Problem with v3 Drop 19 in Vista...

Topics: General Discussion Forum
Apr 20, 2007 at 12:34 AM
Hi all,

I just installed the latest version of Service Factory and I'm getting this error when I try to create a new Service:

---------------------------
Microsoft Visual Studio
---------------------------
Package Load Failure

Package 'Microsoft.Practices.ServiceFactory.VsPkg.WebServicesFactory, Microsoft.Practices.ServiceFactory.VsPkg, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' has failed to load properly ( GUID = {3A053D37-49A0-4713-A3C4-6161158FB0C4} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'devenv /resetskippkgs' to re-enable package loading.
---------------------------
Yes No
---------------------------

I'm running VS 2005 Team Suite on Vista Ultimate. I have the previous verson of Service Factory already and it seems to be fine.

For what it's worth, I also tried to install Enterprise Library for 2.0 (failed, unspecified error) and 3 (that one installed and built, haven't played with it yet).

Any help/advice would be a GREAT help.

Thanks,
James
Apr 23, 2007 at 3:09 PM
James,

This version of Service Factory differs significantly from the previous (V2) version. In addition to a GAX package we're now installing a VS Package to handle our models and two DSLs, which are themselves VS packages. This obviously complicates the install somewhat.

Can you confirm that the following key exists and that the CodeBase value points to your VsPkg.dll

HKEYLOCALMACHINE\SOFTWARE\Microsoft\VisualStudio\8.0\Packages\{3a053d37-49a0-4713-a3c4-6161158fb0c4}

Thanks,

Ade

BTW: Have you tried the latest source code drop?
Oct 2, 2007 at 11:31 PM
Hi Ade,

Is there any update on this issue, I'm currently experiencing the same problem with v3b117. The key exist in the registry and points to a valid Microsoft.Practices.ServiceFactory.VsPkg.dll

C:\Program Files\Microsoft Service Factory V3\Guidance Package\Product Definition\Microsoft.Practices.ServiceFactory.VsPkg.dll

However, Visual Studio still throws the Package Load Failure error on startup

Thanks,
Sergio
Oct 3, 2007 at 8:22 AM
I also have this issue ( Vusta Ultima) and the reg key exits.


Some commencts


Guidance Navigator showed an unbound reference...

When running as admin i get the same error but it noticed a dialog recipe framework error with Service.EnvDTE.DTE is required for component

Regards,

Ben