trouble with WCF Hands-on Lab Excersize 5

Topics: General Discussion Forum
Mar 29, 2007 at 7:46 AM
Hi,
ting stuck at
I am going through the WCF hands-on labs for the service factories. I am get stuck with step2 of excersize 5 "Create Business Entities from an Existing Data Model". Every time I lunch the create business entities from Data source wizard, it comes up empty in the drop box for the Service host name.
I am running the labs on Vista.
Any ideas?

thx,

Husni



Mar 29, 2007 at 4:24 PM
We need to verify that you have the "Coho.ClubServices.Membership.Host" set with a "Host" responsability.
Here are the steps:
  1. Right click your solution and select "Service Factory (WCF)" option and click "UnLock solution".
  2. Right click "Service Factory (Data Access)" on the "Coho.ClubServices.Membership.Host" and select "Specify project responsability".
  3. Check that you have "Host project" checked.
Now try to repeat the steps in Ex5 and you should be fine.

Charly


Mar 30, 2007 at 7:02 AM
Charly,

thanks for your help. The host project was not set with host responsibility. However, when I tried to do that as outlined in the steps above, I got this error message:

Microsoft.Practices.RecipeFramework.ValueProviderException: An exception occurred during the binding of reference or execution of recipe SpecifyProjectResponsibility. Error was: An error happened while calling the value provider or evaluating the default value of argument IsBusinessEntityProject..
You can remove the reference to this recipe through the Guidance Package Manager. ---> System.Runtime.InteropServices.COMException (0x80004005): Cannot set the value in the Globals object: the file to store the value in cannot be written to.
at EnvDTE.Globals.set_VariableValue(String VariableName, Object pVal)
at Microsoft.Practices.RecipeFramework.Extensions.ValueProviders.VisualStudio.ProjectGlobalsEntryProvider.OnBeforeActions(Object currentValue, Object& newValue)
at Microsoft.Practices.RecipeFramework.Recipe.CallProviders(IDictionary providers, IDictionaryService readonlyArguments, IDictionaryService arguments, Boolean isBefore)
--- End of inner exception stack trace ---
at Microsoft.Practices.RecipeFramework.Recipe.CallProviders(IDictionary providers, IDictionaryService readonlyArguments, IDictionaryService arguments, Boolean isBefore)
at Microsoft.Practices.RecipeFramework.Recipe.Execute(Boolean allowSuspend)
at Microsoft.Practices.RecipeFramework.GuidancePackage.Execute(String recipe, IAssetReference reference, IDictionary arguments)
at Microsoft.Practices.RecipeFramework.GuidancePackage.Execute(IAssetReference reference)
at Microsoft.Practices.RecipeFramework.RecipeReference.OnExecute()
at Microsoft.Practices.RecipeFramework.AssetReference.Execute()
at Microsoft.Practices.RecipeFramework.VisualStudio.RecipeMenuCommand.OnExec()

husni
Mar 30, 2007 at 3:40 PM
I had the same issue. I followed Charly's instructions about setting the Host responsibility and also got the error message. I had problems with Read-Only solution files (.sln) in previous steps. So, I exited the solution, changed the file Properties for my .sln file (and all other files, just to be sure) so that they were not Read-Only. I re-opened the solution, followed the steps to give Host responsiblity to Coho.ClubServices.Membership.Host and everything worked!
Mar 30, 2007 at 5:37 PM
Thanks husini, we have noticed the problem and we'll soon upload a refresh version (WCF & ASMX) without the read only flag.

Charly.
Mar 30, 2007 at 5:46 PM

zoescout wrote:
I had the same issue. I followed Charly's instructions about setting the Host responsibility and also got the error message. I had problems with Read-Only solution files (.sln) in previous steps. So, I exited the solution, changed the file Properties for my .sln file (and all other files, just to be sure) so that they were not Read-Only. I re-opened the solution, followed the steps to give Host responsiblity to Coho.ClubServices.Membership.Host and everything worked!


Thanks zoecout. turning off the read-only from the entire solution directory solved this problem.
Husni
Mar 31, 2007 at 12:31 AM
Just today I reposted the HOLs after I turned off the read-only bit on all of the files in the ZIP files. So, no one else should experience this problem. Sorry for the inconvenience. That's what I get for not checking them out before compressing them :)

Don