Recipe Runner problem

Topics: July and December Releases Forum
Jan 31, 2007 at 1:48 PM
Just tried the recipe runner, but failed at step3. What could be causing this problem? Thanks.

Error Message:
Initialization method SimpleTestingPackageRecipeTests.RecipeRunnerFixture.TestInitialize threw exception. System.Runtime.InteropServices.COMException: System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x80040104.

Stack Trace:
at EnvDTE80.DTE2.ExecuteCommand(String CommandName, String CommandArgs)
at GaxTestIntegration.Helpers.TestHelper.GetRecipeRunnerService(DTE2 dte) in D:\BluePineProjects\Guidance Pakcage Development\GAX RecipeRunner\GaxTestIntegration\GaxTestIntegration\Helpers\TestHelper.cs:line 38
at GaxTestIntegration.Test.BaseFixture.TestInitialize(Assembly assembly, String resourceName, String solutionFileName) in D:\BluePineProjects\Guidance Pakcage Development\GAX RecipeRunner\GaxTestIntegration\GaxTestIntegration\Test\BaseFixture.cs:line 24
at SimpleTestingPackageRecipeTests.RecipeRunnerFixture.TestInitialize() in D:\BluePineProjects\Guidance Pakcage Development\GAX RecipeRunner\GaxTestIntegration\GaxTestIntegrationTests\RecipeRunnerFixture.cs:line 34
Jan 31, 2007 at 5:08 PM
Can you send us all the steps you did to repro this issue? And the enviroment you are running this application test.
You may also make sure that the error does not come from some action inside the recipe like some DB connection issue or the like.

Thanks,
Hernan
Feb 1, 2007 at 9:09 PM
Did you register the SimpleTestingPackage?
Feb 2, 2007 at 2:40 PM
I just followed the steps in this link http://www.codeplex.com/servicefactory/Wiki/View.aspx?title=GaxRecipeRunner&referringTitle=Home


Yes, I did register SimpleTestingPackage.

Thanks.