Cannot browse WCF in Vista

Topics: General Discussion Forum, Service Factory Modeling Edition Forum
May 7, 2009 at 7:41 PM
Hello,
I know this might sound silly, but I am going through the Hands on lab and I completed most of them. But when I generate the service code by building the host, I try to launch it in IE (with "View in Browser") and I get an error on the page that "Internet explorer cannot display the page" (I disabled the "show friendly HHTP error messages" but that's still all it tells me).
Hence, the client cannot see the host either.

I am sure it is something to do with Vista or IE8 (and my ignorance of).
Thanks for your kind advice.

Cos
Developer
May 8, 2009 at 12:43 PM

Did you checked this? http://support.microsoft.com/kb/956196

You can also make sure that you are navigating to a URL that incluides the service page (.asmx or .svc).

May 8, 2009 at 1:36 PM

Hernan,

thanks for replying. What I noticed is that the "Build Web Site" command does not actually create an .svc file in the test folder. I generated the code and built everything, but the App_Code folder stays empty and no .svc file is created in the Test folder.

There is something I must be missing

 

Cos

May 8, 2009 at 2:02 PM

Here's what I had to do. so far:

1 - Start VS2008 as Administrator
2 - Open the solution
3 - Publish the WCF Host as a website on IIS

Now I can see the svc, but when I try to generate a client proxy

"Metadata contains a refence that cannot be resolved...http://myPC/myService.svc/mex..."

Not a smooth ride..

Developer
May 8, 2009 at 9:34 PM

There's a property in host designer that let you enable metadata exchange so you may browse the .svc without the warnings.

May 8, 2009 at 10:13 PM

I already have that set to true…

May 9, 2009 at 3:13 PM

So, I went ahead and install the factory on my Win 2003 machine. Copied the solution, and it works like a champ without touching anything.

I must have missed something in the configuration steps for the Factory for Vista (or maybe it's because I have Home Premium)... one more reason to love Vista.