Project Type: "Guidance Packages/Service Factory: Modeling Edition" not found

Topics: Service Factory Modeling Edition Forum
Jan 11, 2009 at 5:31 AM

I used the source code installer for WSSF, following the steps in the documentation.  Everything seemed to install successfully, but when I go to create a new project in VS 2008, "Guidance Packages/Service Factory: Modeling Edition" does not show up in project types.  WSSF is not listed in installed program list either.  I used to have the binary version intalled and I was able to create Service Factory types fine.  I uninstalled it and then installed the source code version so I could incorporate the ImportWsdl recipe.  Please help.  Thanks.     

Jan 11, 2009 at 12:38 PM
When using the source code, you will need to open VS under experimental hive (When testing your model, this is after building the source solution). You can find a shortcut for this in the VS SDK menu under Tools named "Start Microsoft Visual Studio 2008 under Experimental hive".
Don't forget to build the sln with a normal instance of VS after opening the test VS instance under Experimantal hive.
You may also need to "Reset the Experimentla hive" if you make changes to the model. For this you will also find an option under SDK\Tools menu option.
Jan 11, 2009 at 6:37 PM
Thank you.  That worked.  I am now able to open up a solution I created under the binary install of WSSF and create new projects.  However, the "Import from Wsdl" context menu doesn't appear in the service contract model.  I'll try reinstalling everything again. 
Jan 11, 2009 at 8:55 PM
I get  "Guidance Packages/Service Factory: Modeling Edition" project type now but I can't install "Import Wsdl" recipe.  One of the steps requires reseting the experimental hive which which blows away my WCCF source install.  Then I can't open an SF project and I have to reinstall WCCF.  Any ideas?
Jan 12, 2009 at 7:18 PM
After reseting the Exp hive, try rebuilding the WSSF source solution. If that blows your sln, check if you have followed all the installations steps in the "Import WSDL" recipe. BTW, if you can send the error message when the sln blows, that may also help.

Thanks,
Hernan
Jan 12, 2009 at 10:42 PM

That’s exactly what the directions for setting up ImportWsdl says (see below).  However, my WSSF project won’t open up when I complete these last two items saying it doesn’t recognize “ssfproject” (or “ssfproduct”) and the project type doesn’t show up when I go to open a new project.   Thanks.

 

 

8. Reset the Visual Studio 2008 Experimental Hive by executing the tool located at Start Menu à All Programs à Microsoft Visual Studio 2008 SDK à Tools à Reset the Microsoft Visual Studio 2008 Experimental hive.

 

 

9. Build the Service Factory Guidance Package project, after the build succeeds register the package. To do this right click on the project’s icon and click on the Register Guidance Package option.

Jan 13, 2009 at 12:01 AM
Notice that the full build for WSSF sln should be done under regular hive and with admin privs.