Cabinet File Error 2350

Topics: July and December Releases Forum
Jan 22, 2007 at 5:30 PM
Hi,

I am getting the following error while installing any of the following WCF msi files included in the Dec 2006 WSSF!

WCF Guidance Package Source Code
WCF Reference Implementation Source Code
WCF Security Guidance Package Source Code

Error:
The cabinet file <file name.cab> required for this installation is corrupt and cannot be used. This could indicate a network error, an error reading from the CD-ROM, or a prlblem with this package.

Once I press "Ignore" on the dialog box shown, I get the following error:

The installer has encountered an unexpected error installing this package. this may indicate a problem with this package. The error code is 2350.

Why am I getting these error? I am the admin on the box and am able to install the WSSF just fine.

By the way, I downloaded the WSSF three times, and reinstalled it thrice but the behavior is still the same! (strange thing is that this error occurs only for WCF packages, not for ASMX packages)

Any help is appreciated.

Thanks.
Coordinator
Jan 24, 2007 at 4:35 PM
I just wanted to let you know that I'm not ignoring you. I just don't know the answer ... yet. The only thing I can think of is you might be encountering the "long pathname error". I can't remember what error this problem displays, but I know it is not helpful. Try to extract the source code to "C:\Source" or something like that. This issue is in the Known Issues document that we link to from the "Home" page of this community site.

If this doesn't help, be sure you have all of the system requirements installed. If that doesn't help, email me at dons@microsoft.com and I'll get you in touch with someone who can help. Thanks,

Don
Coordinator
Jan 26, 2007 at 1:19 AM
If you're not experiencing the long filename problem I mentioned above, and you please give us more information? What operating system are you using? Were you able to sucessfully install it at least once? We know there are issues sometimes when you try to install it into a folder that already exists - we just want to make sure you are not doing that. We appreciate any more information you can give us that will help us track this down. Thanks,

Don
Coordinator
Jan 26, 2007 at 4:51 AM
This is the copy of a thread I found in my inbox a moment ago from Chris, the Service Factory v2 Dev Lead:

From: Chris Tavares
Sent: Friday, January 26, 2007 1:32 AM
Subject: RE: can't install GP sources

This is a known issue that occurs when the total path of files installed by the MSI get past MAX_PATH. As you know, we tend to be rather verbose with files and directory names around here, so there’s not a whole lot of room left over.

Change the default install path to something like “C:\Dev” instead of “C:\Documents and Settings\<username>\<username>’s Documents\Visual Studio 2005\projects” and you’ll be just fine.

This was supposed to make it into the known issues doc before release, but it somehow the doc update got missed.

-Chris

----------------------------------------------

Sent: Thursday, January 25, 2007 7:49 PM
Subject: can't install GP sources

Hi,

I’ve downloaded WSSF DEC06 MSI and installed it ok, then I tried to install the MSI for WFC Security Guidance Package source code and I got an error “file WCFSecGPSource.cab is corrupt and cannot be used” while installing. I then tried installing source for another guidance package and hit the same error (pointing to another .cab file).

I downloaded the MSI twice and tried on my host and one VPC machine, all failed with the same error.

Is this a known issue?

Thanks

----------------------------------------------

So, if this is not the source of the issue you experienced, please let me know. Otherwise, I will assume this fixes it. I'm also going to resolve the associated issue in "Issue Tracker". I can always reopen it if needed. Thanks!