DIS Package Load Failure (VS2008 + VS2008SP1)

Topics: Service Factory Modeling Edition Forum
Aug 27, 2008 at 8:44 AM
Hello,

i am currently developing a dsl (VS2008), which is using the dsl integration service included in the web-service software factory modeling editon feb 2008. Running the DSL as debugging project within the experimental hive implies the following problem: As soon as i want to launch the DIS-UITypeEditor by clicking on the button beside the "mel://" property field i get the error:

"Package Load Failure. Package 'Microsoft.Practices.Modeling.Dsl.Service.DslIntegrationPackage, Microsoft.Practices.Modeling.Dsl.Service, Version 3.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' has failed to load properly (GUID={4ca249ec-ba85-4537-b541-d3e4561044dd}....."


The Package-Load-Failure occurs only within the Experimental hive. The Package works properly within the standard environment. I tried also what was discussed here :

  • http://forums.msdn.microsoft.com/en-US/vsx/thread/07047557-b8a0-4f23-b29a-1432355184aa
  • http://www.codeplex.com/servicefactory/WorkItem/View.aspx?WorkItemId=4076
namely :
  • Reinstalling the wssf
  • Resetting the experimental hive
  • Installing all on a new blank machine
But nothing helps. Additional info: The Package- Load-Analyzer shows no errors.
Thank you for your support-tips in advance.

ujsr
Feb 27, 2009 at 11:12 AM
I have the same problem, i registered the package manually, reset the exp hive, tried everything, nothing help...
Developer
Feb 27, 2009 at 4:37 PM
Do you have "Microsoft.Practices.Modeling.Dsl.Service.dll" GACed and signed with this PK token: 31bf3856ad364e35 ?
Mar 2, 2009 at 8:51 AM
YES
Developer
Mar 3, 2009 at 4:37 PM
Also check that you don;t have the binary and source version installed on the same box. In case you are trying with the Exp hive, I assume that you are using the source version so you may not have the binary version installed. Otherwise uninstall it.
You may also try using the Package load analyzer (samples here: http://blogs.msdn.com/aaronmar/archive/2007/04/02/package-load-analyzer.aspx and here http://blogs.msdn.com/dr._ex/archive/2006/12/14/debugging-package-load-failures.aspx).
Mar 4, 2009 at 8:45 AM
I tried to use the package load analyzer included in the vstudio 2005 SDK but it seems to cause version conflicts with vstudio 2008 SDK assemblies (ver 8.0 against ver 9.0)...building the source code I get errors ...If I unistall the 2005 SDK all returns normal...is it possible to install only the package load analyzer tool without install all 2005 SDK?
Developer
Mar 4, 2009 at 9:40 AM
You already have rhe PLA included in VS SDK 2008.
You can find it in Tools menu of VS IDE.
This link http://blogs.msdn.com/dr._ex/archive/2006/12/14/debugging-package-load-failures.aspx show some common scenarios where you can trace issues with this tool.