Very Poor Performance on 2008!?

Topics: Service Factory Modeling Edition Forum
Mar 10, 2008 at 1:14 PM
Edited Mar 10, 2008 at 1:16 PM
Yesterday I upgraded and installed the 2008 version of WSSF: Modeling Edition and I find the performance in the model diagrams to be very poor compared to 2005. Is this related to the 2008 version, or updates done in the last few months? Is there any tip on what I can do to improve the performance? Machine is a 3GB RAM, Intel T7200 2GHz and Windows Vista.

The service diagram is very simple and still it takes 5-6-7 seconds when I drag one of the service Operations around on the surface... This is not good and it gives me doubts regarding the tools...

On wednesday I'm doing a course on WSSF: Modeling Edition and will probably have to use the 2005 version cause the slowness in 2008 will be unbearable...
Developer
Mar 10, 2008 at 8:49 PM
We are aware of this issue and we are working to get a hot fix.
If you need ASAP a quick fix, try opening the Microsoft.Practices.Modeling.ExtensionProvider.Serialization.GenericSerializer class in the source code of WSSF:ME (if you already installed the binary version, uninstall it and install the source code version following the installation steps).
In that class, go to "Serialize<T>(object obj, Type[] types)" and comment all the try/catch block and leave only the code inside the catch block so you should end up with something like this:

public static string Serialize<T>(object obj, Type[] types)
{
     Guard.ArgumentNotNull(obj, "obj");
     Guard.ArgumentNotNull(types, "types");
 
     string text;
 
     BinaryFormatter formatter = new BinaryFormatter();
     using (MemoryStream stream = new MemoryStream())
     {
          formatter.Serialize(stream, obj);
          stream.Position = 0;
          text = Convert.ToBase64String(stream.ToArray());
     }
     return text;
}
Mar 28, 2008 at 2:15 PM
Is there any news on when the hotfix for this will be available?

Or has anyone out there successfully patched this themselves using the instructions above as I tried it myself and encountered problems and didn't have the time to resolve them.
Developer
Mar 28, 2008 at 3:33 PM
There is a new download available from the MSDN service factory site to address this. You will need to uninstall the current version and install this one.

-b
Mar 28, 2008 at 10:08 PM
Excellent. Thats fixed it for me.

Thanks.