SF Modeling Edition (VS2008) Installation problem

Topics: Service Factory Modeling Edition Forum
Mar 4, 2008 at 6:42 AM
Hi,

I have installed WSSF for VS 2008, and when I have started solution rebuild occurred following exceptions:

Error 1 Metadata file 'D:\Projects\WssfSrc\Data Contract DSL\DslPackage\bin\Debug\Microsoft.Practices.ServiceFactory.DataContracts.DslPackage.dll' could not be found Microsoft.Practices.Modeling.ExtensionProvider.Tests
Error 2 Can't start preprocessor (2) D:\Projects\WssfSrc\Data Contract DSL\DslPackage\CTC DataContractDslPackage
Error 3 Can't start preprocessor (2) D:\Projects\WssfSrc\Data Contract DSL\DslPackage\CTC DataContractDslPackage
Error 4 Can't start preprocessor (2) D:\Projects\WssfSrc\Service Contract DSL\DslPackage\CTC ServiceContractDslPackage
Error 5 Can't start preprocessor (2) D:\Projects\WssfSrc\Service Contract DSL\DslPackage\CTC ServiceContractDslPackage
Error 6 Can't start preprocessor (2) D:\Projects\WssfSrc\Host Designer DSL\DslPackage\CTC HostDesignerDslPackage
Error 7 Can't start preprocessor (2) D:\Projects\WssfSrc\Host Designer DSL\DslPackage\CTC HostDesignerDslPackage


Than I noticed that in %WINDIR%/assembly missing package dll-s :

◦ Microsoft.Practices.ServiceFactory.DataContracts.DslPackage

◦ Microsoft.Practices.ServiceFactory.HostDesigner.DslPackage

◦ Microsoft.Practices.ServiceFactory.ServiceContracts.DslPackage


Next what I got that is wrong or wantage is in registry tree (or I am wrong ? ). There is missing

HKEYCURRENTUSER\Software\Microsoft\VisualStudio\9.0Exp node,

I know in WSSF for VS2005, that after “hiving”, 8.0 is copied to the 8.0Exp, know there isn’t this node is this ok?

I have followed installation guide for Source installation. What is wrong?

I’ am working on OrcaBeta2 and Win2003 .

Regards
Developer
Mar 4, 2008 at 11:22 AM
Hi,

As far as I know, the WSSF:ME for VS2008 was not tested with Orcas Beta 2, so I guess you should try with VS2008 release version. That might be the reason why you can't find the 9.0Exp registry entry. Remember that the source installation does not check which version of VS2008 you have so you can expect some errores in case you don't have the appropiate requirements in place, like in this case, 2008 RTM.
Mar 4, 2008 at 12:13 PM
Hi Charly,

i made the rebuild working on, the problem was in fact the non installed C++ support for VS OrcasBeta2, after installation registration has been finished.

Now i have all dll-s in assembly repository and 9.0 Exp tree.

But there are new problems ;) In Exp when i select WSSF GP project i got following exception msg :

A problem was encountered creating teh Sub project "Service4" . The project file C:\Documents and Settings\MyAccount\Local Settings\Temp\dsdd45\Temp\Service4.ssfproduct cannot be opened.

The project type is not supported by this installation.

and then i got that on reg tree HKEYCURRENTUSER\Software\Microsoft\VisualStudio\9.0Exp\Configuration\Packages\{77d93a80-73fc-40f8-87db-acd3482964b2}\Templates

there is not key for WSSF

and why it looks for modeling extension in temp directory ?

Do you think that is also possibility of Orcaseta2 or it's maybe well-known problem?

Thanks a lot

R
Developer
Mar 4, 2008 at 12:46 PM
In 2008 RTM you may fix this simply by reseting the ExpHive and rebuilding+registering. Now in Beta2, this is as I mentioned before, "unexplored territory" so you may keep with trial/error or try getting RTM.
One quick question, did you install VS2008 SDK successfully with Beta2? And the rest of the requirements like GAX 1.4?
Mar 4, 2008 at 1:14 PM
Yes, the installation of requirements were ok. I will try now with RTM

Thanks
Mar 5, 2008 at 9:42 AM
I made it with RTM, it's working ok now.

Thank you Charly