No Commands Available

Topics: Service Factory Modeling Edition Forum
Feb 29, 2008 at 3:41 AM
I downloaded the VS 2008 service factory modeling edition.

When I right click on the message contract it says "No Commands Available" - There is add pimtive data part or Data Contract part commands?

When I open the Blu Yonder Solution, I can not add any contract or part members.
Developer
Feb 29, 2008 at 12:06 PM
Do you have all the requirements installed? OS version?

Thanks,
CF
Mar 10, 2008 at 9:00 PM

There are no commands (neither primitive data nor Data contract).

I am running VS 2008 RTM on Vista.
Developer
Mar 10, 2008 at 10:00 PM
Did you install VS2008 SDK?
Are you running the binary or source version of WSSF:ME ?

Thanks,
CF
Mar 13, 2008 at 7:56 PM
I have VS2008 SDK 1.0, I reinstalled Guidance Extension and Automation Tool Kit and reinstalled the modeling eidition; But when I create a new model and drop any of the objects (Contracts, operations, message - ) and right click, I see no commands available.

I am running the binary version.

thanks
Developer
Mar 14, 2008 at 12:51 AM
Try running DEVENV /SETUP from the "..\Microsoft Visual Studio 8\Common7\IDE" from within a command prompt that is started with "Run as Administrator".
Apr 18, 2008 at 10:18 PM
I am having the same problem , i have installed Web service software factory for modelling edition. After creating the solution , if i right click the model it says "No commands available"

Environment : VS2008 Professional edition in Windows XP

Please help
Developer
Apr 21, 2008 at 2:10 PM
Try reseting the experimental hive and reinstall WSSF, GAX and VS-SDK (all reqs but VS) (All 2008 versions).
Apr 22, 2008 at 1:03 PM
Hi,

Thanks for your note. I tried to do the same but still getting the "No commands available" disabled.