Still Cannot Install VS2008 Edition!!! Error 1001

Topics: Service Factory Modeling Edition Forum
Feb 18, 2008 at 12:11 AM
Edited Feb 18, 2008 at 12:12 AM
After everything I went through in this topic [url:http://www.codeplex.com/servicefactory/Thread/View.aspx?ThreadId=21835}, I figured it was me, so I repaved the machine and started fresh and it still does NOT install! I get "Error 1001: The project factory CSharp is not registered, template c:|Program Files\Microsoft Service Factory V3\Guidance Package\Templates\Items\DataContractModel.vstemplate cannot be installed."

I am concerned about the quality and the diifficulty for the average developer (not me) with this combination of GAX + GAT + factories. This stuff is nearly impossible to install and definetly impossible to unistall as the previous topic installed.

There is nothing on this machine other than this:

1. Vista Ultimate
2. Installed VS2008 Team Suite
3. Installed GAX Feb 2008
4. Installed GAT for VS2008 Feb 2008
5. Installed VS2008 SDK
6. Tried to install this and got error

Please help.....
Feb 18, 2008 at 2:24 AM
I have the same problem. I have installed the February edition GAX and GAT successfully. But I can not install the VS 2008 CTP Modeling Edition. I get the exact error.
Feb 18, 2008 at 3:25 AM
I spent days getting this to work with VS 2008. I found it was using bits of vs2005 and would only work when i had both versions installed. Hope you have an MSDN license.
Feb 18, 2008 at 3:45 AM
I cannot believe how fragile this GAX/GAT stuff is.


jdobrien wrote:
I spent days getting this to work with VS 2008. I found it was using bits of vs2005 and would only work when i had both versions installed. Hope you have an MSDN license.

Feb 18, 2008 at 4:58 AM
Yup, it only installs if BOTH VS2005 and VS2008 are installed CONTRARY to what the new Gax/GAT feature set says. And once installed, it still doesn't work.



jdobrien wrote:
I spent days getting this to work with VS 2008. I found it was using bits of vs2005 and would only work when i had both versions installed. Hope you have an MSDN license.

Feb 18, 2008 at 6:37 AM
That's strange. I never had any installation issues. Neither with Visual Studio 2005 and 2008. I've just reinstalled a Windows XP Sp2 system and installed only Visual Studio 2008 and the February CTP. No issues at all. I've also bought myself a new Vista Business laptop and did the exact same thing. The only problems we ran into since it's first inception in March 2007 are uninstallation problems. For instance, a colleague of mine had to manually remove all assemlbies and Registry keys to get the CTP to install properly.
Feb 18, 2008 at 9:58 AM
Dennis, did you also install the latest version (Feb) of GAT\GAX? This problem seems to occur only against this latest release of GAX.



dennisdoomen wrote:
That's strange. I never had any installation issues. Neither with Visual Studio 2005 and 2008. I've just reinstalled a Windows XP Sp2 system and installed only Visual Studio 2008 and the February CTP. No issues at all. I've also bought myself a new Vista Business laptop and did the exact same thing. The only problems we ran into since it's first inception in March 2007 are uninstallation problems. For instance, a colleague of mine had to manually remove all assemlbies and Registry keys to get the CTP to install properly.

Feb 18, 2008 at 12:46 PM
Notice that the current WSSF CTP will run with GAX 1.3 (July 2007) so you should wait until final release of WSSF (soon) that will run with the new GAX 1.4
Feb 18, 2008 at 3:44 PM
No the people here said that the current drop would work with the new GAX. In fact, they told me to wait a few days for it! You guys need to get very explicit about EXACTLY which versions of each piece are required and what versions have been tested. It doesn't work on Vista Ultimate period. I started with a new image.




charlyfriend wrote:
Notice that the current WSSF CTP will run with GAX 1.3 (July 2007) so you should wait until final release of WSSF (soon) that will run with the new GAX 1.4

Feb 18, 2008 at 4:13 PM
The Feb WSSF:ME CTP will not work with its current install and GAX 1.4. For GAX 1.4, we had to make a tough decision about the default platform when installing guidance packages and that decision is to target VS2005 by default. Since there are only CTP releases for guidance packages on VS2008, this meant the change would only affect CTPs versus affecting all the released, VS2005 guidance packages.

If you have Orca (msi editing tool), you can change this in the MSI by adding a /Hive=9.0 to the custom actions.

At this point, we are not planning to rev the CTP as we are hoping to get the final release out near the end of the week. I'll update the CTP release page to reflect this note.

-b


sgentile wrote:
After everything I went through in this topic [url:http://www.codeplex.com/servicefactory/Thread/View.aspx?ThreadId=21835}, I figured it was me, so I repaved the machine and started fresh and it still does NOT install! I get "Error 1001: The project factory CSharp is not registered, template c:|Program Files\Microsoft Service Factory V3\Guidance Package\Templates\Items\DataContractModel.vstemplate cannot be installed."

I am concerned about the quality and the diifficulty for the average developer (not me) with this combination of GAX + GAT + factories. This stuff is nearly impossible to install and definetly impossible to unistall as the previous topic installed.

There is nothing on this machine other than this:

1. Vista Ultimate
2. Installed VS2008 Team Suite
3. Installed GAX Feb 2008
4. Installed GAT for VS2008 Feb 2008
5. Installed VS2008 SDK
6. Tried to install this and got error

Please help.....

Feb 25, 2008 at 7:37 AM

brumfb wrote:
...
If you have Orca (msi editing tool), you can change this in the MSI by adding a /Hive=9.0 to the custom actions.
...


How to add the parameter to the custom actions?
Feb 25, 2008 at 8:35 AM
Moin Moin.

I am new to orca, but where does one know the "type"number of the "/Hive=9.0" tag.
_Tschuess,
__Michael.

brumfb wrote:
The Feb WSSF:ME CTP will not work with its current install and GAX 1.4. For GAX 1.4, we had to make a tough decision about the default platform when installing guidance packages and that decision is to target VS2005 by default. Since there are only CTP releases for guidance packages on VS2008, this meant the change would only affect CTPs versus affecting all the released, VS2005 guidance packages.

If you have Orca (msi editing tool), you can change this in the MSI by adding a /Hive=9.0 to the custom actions.

At this point, we are not planning to rev the CTP as we are hoping to get the final release out near the end of the week. I'll update the CTP release page to reflect this note.

-b


sgentile wrote:
After everything I went through in this topic [url:http://www.codeplex.com/servicefactory/Thread/View.aspx?ThreadId=21835}, I figured it was me, so I repaved the machine and started fresh and it still does NOT install! I get "Error 1001: The project factory CSharp is not registered, template c:|Program Files\Microsoft Service Factory V3\Guidance Package\Templates\Items\DataContractModel.vstemplate cannot be installed."

I am concerned about the quality and the diifficulty for the average developer (not me) with this combination of GAX + GAT + factories. This stuff is nearly impossible to install and definetly impossible to unistall as the previous topic installed.

There is nothing on this machine other than this:

1. Vista Ultimate
2. Installed VS2008 Team Suite
3. Installed GAX Feb 2008
4. Installed GAT for VS2008 Feb 2008
5. Installed VS2008 SDK
6. Tried to install this and got error

Please help.....


Feb 25, 2008 at 9:06 AM
As I understood it, the poster meant to add that argument to the installer action line:
Installbdb0ce04fa534bb184e9151793ba0652.SetProp

to read something like:
/installtype=notransaction /action=install /LogFile= /DesignMode /Hive=9.0 /Configuration="GuidancePackageDirService Factory Guidance Package (binary release).xml" "FileId_7cc56ca8e75a49b896153b16b093356d" "FileId_31e422357a1c4469adb76619e7e90afb"

But in any case, while that let me install, it threw an error when trying to create a new project based on one of the templates.
Mar 18, 2008 at 4:25 AM
I have a great idea. Lets try and get all the GAX/GAT, Enterpreise Library 3.x/4.0 and WCSF and WSSF and SCSF on 2008!!!!!! so we don't have to spend WEEKS trying to edit .msi files and perform magic tricks dumping files and learning how to manually remove registry entries. Lets get these tools to work with the 2008 which has been RTM for some time now.

I spent three weeks on and off hoping that someone can respond with a solution to these installation issues and all we get is a five page summary of how someone thinks they know how to make all these things install together.

This is crazy. I'm on this post because I got the same error with Enterprise libary 3.1 which does not install on 2008. I also have GAT/GAX Service Provider is null Recipie Framework Errors and no one on CodePlex seems to be able to respond to that one.

I would really like to build an ASP.NET MVP application on a fresh VMWare Windows XP SP2 with 2008 installed.
I can install GAX/GAT 2008 fine.
I cannot install Ent Lib 3.1
Ent Lib 4.0 is delayed - only a thousand blog sites but no official site with any real date. Nice! Why can't 4.0 be a Codeplex project ?
Creating a Guidance Package Solution - Recipie Framework Error - value cannot be null service Provider in you guessed it the TemplateWizard.
http://www.codeplex.com/websf/Thread/View.aspx?ThreadId=16993

Fact: I have no options to create an ASP.NET MVP application with 2008.

Please someone explain how I can do this without editing msi files and dumping my whole machine out for someone to play detective and try to ask me a hundred questions about what I did wrong.

thank you
Mar 18, 2008 at 1:58 PM
Currently you have WSSF:ME, GAX/GAT and WCSF available for 2008 so you shouldn't have issues installing them with VS2008 and the rest of requirements. Regarding EntLib, I don't know when it will be avaialble a version for VS2008 but beside that, I don't see a blocking issue for start using the rest of the factories and then start using EntLib for VS2008 when available.
Mar 20, 2008 at 6:19 AM
Hello charlyfriend, thanks for the post but I can't find any solution to this problem which I've seen other posts on.

Please please please someone tell me what is wrong with GAX/GAT on 2008. I'm not even trying to use WCSF yet!

Steps
- install 2008 on new vm (xp)
- install gax 2008 feb - fine
- install gat 2008 feb - fine
- OPen VS - choose guidance package - any of them...
Error Below.

Recipie Framework Error
System.ArgumentNullException: Value cannot be null.
Parameter name: serviceProvider
at Microsoft.Practices.ComponentModel.ServiceHelper.GetService(IServiceProvider serviceProvider, Type serviceType, Object component)
at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.VszWizard.EnvDTE.IDTWizard.Execute(Object Application, Int32 hwndOwner, Object[]& ContextParams, Object[]& CustomParams, wizardResult& retval)

I can send a dump from gax troubleshooter if you want. I'm hoping someone can actually use this stack trace and tell me what would make that fail, instead of trying to find a needle in the haystack. Tonight, I un-installed 2008 and back again and same problem - then I removed 3.5 using a msi remove tool and repaired vs2008 - same problem.

Can someone please look at the source and determine what could be the cause ? I can also send you the gax troubleshooter dump. and recipieframework xml.....

thanks
Marty
Mar 20, 2008 at 9:06 AM
Moin Moin.

Sounds familiar.
_Tschuess,
__Michael.
May 23, 2008 at 10:23 AM


charlyfriend wrote:
Notice that the current WSSF CTP will run with GAX 1.3 (July 2007) so you should wait until final release of WSSF (soon) that will run with the new GAX 1.4


Soon ?
Feb, Mar, Apr, May, .... :(

May 23, 2008 at 11:53 AM
dotAge: 
    You have since Feb-08, WSSF RTM that runs with GAX 1.4. 
    You also have Entlib 4 that runs under VS2008.
MSpallone: 
    Did you find a solution to your installation issue?

Thanks,
CF