IDE Error: Can't connect two boxes with Toolbox Connector

Feb 15, 2008 at 6:20 PM
Hi,

It's quite difficult to explain the behavior with words.... A video would have been better, anyway... open your minds! :)

I'm following the hands-on-lab and in Exercice 1/Step 12, the step says: "In the Toolbox, click the Connector, and then drag from the DemandRequest message to the GetRequirementDemand operation".

I'm not sure if I'm "slow" or clumsy, but I can't seem to achieve this step ! I tried various combinations of "hotspots/areas of the DemandRequest message" and "click vs Click+drag".

The behavior is always the same: when using the "click" method, the Connector toolbox item gets deselected and the hotspot item in the "DemandRequest" box gets selected. when using the "click+drag" method, the result is that the whole box moves instead of "connecting".

It's is as if there was a IDE/DSL engine/GAX not kicking in properly.

I'm using the latest Web Service Software Factory software on VS2005 TS (SP1) on Vista.

Here's a subset of the output from GaxTroubleshooter:

Key: HKEYLOCALMACHINE\Software\Microsoft\Guidance Automation Extensions
Value CurrentVersion=1.3 - (String)
Key: HKEYLOCALMACHINE\Software\Microsoft\Guidance Automation Extensions\Compatibility
Value 1.1=1 - (DWord)
Value 1.2=1 - (DWord)
Key: HKEYLOCALMACHINE\Software\Microsoft\Guidance Automation Extensions\Hosts
Key: HKEYLOCALMACHINE\Software\Microsoft\Guidance Automation Extensions\Hosts\VisualStudio
Value CurrentHive=8.0 - (String)
Value CurrentInstallDir=C:\Program Files\Microsoft Visual Studio 8\ - (String)
Dumping GAX Main Manifest...


However, I do have this error later in the file:

Unable to get assembly info: Microsoft.Practices.RecipeFramework.VisualStudioUI.dll - The module was expected to contain an assembly manifest. (Exception from HRESULT: 0x80131018)

Any thoughts?

Pat
Feb 15, 2008 at 7:14 PM
Woh.

That's weird, I got it working once.

But then, I deleted the connector to recreate it. Doesn't work, again.

I tried restarting VS, rebooting...

Pat
Feb 15, 2008 at 7:14 PM
Edited Feb 15, 2008 at 7:16 PM
I will continue testing from home....
Feb 28, 2008 at 6:55 PM
I found the problem: If the toolbox is floating (not docked) the problem appears. Solution: Just dock the toolbar!

Pat