Installation issue with webservice software factory and Guidance automation toolkit

Topics: General Discussion Forum, July and December Releases Forum, Service Factory Modeling Edition Forum
Feb 8, 2008 at 3:13 AM
Hi,

I am a beginner in WCF, so i would like to have one more clarification.

I have to follow Webservice Software Factory patterns while creating my WCF service.



I had gone through the requirements,

http://msdn2.microsoft.com/en-us/library/aa480534.aspx

Requirements are :

Microsoft Windows 2000, Windows XP Professional, Windows Server 2003, or Windows Vista operating system
Microsoft .NET Framework 3.0
Microsoft Visual Studio 2005 (with the exception of the Express edition)
Microsoft SQL Server 2005 Express Edition or SQL Server 2005
Guidance Automation Extensions Technology Preview (February 2007 Release for Visual Studio 2005)
I am using Windows XP, i have installed MS VS 2005 pro 90 days trail, MS SQL SERVER 2005 EE,

and i installed GAX.



but i am not able to install web service software factory i my system...

I am facing som issues while installing...



Unable to get Installer types in the c:\ProgramFiles|Microsoft Visual Studio8\Common7\IDE\Public Assemblies\Microsoft.Practices.ServiceFactory.Asmx.Installer.dll assemlby,--> unable to load one or more of the requested types. Retrive the LoaderExceptions Prpoerty for more information.



Unable to get Installer types in the c:\ProgramFiles|Microsoft Visual Studio8\Common7\IDE\Public Assemblies\Microsoft.Practices.ServiceFactory.DataAccess.Installer.dll assemlby,--> unable to load one or more of the requested types. Retrive the LoaderExceptions Prpoerty for more information



Unable to get Installer types in the c:\ProgramFiles|Microsoft Visual Studio8\Common7\IDE\Public Assemblies\Microsoft.Practices.ServiceFactory.WCF.Installer.dll assemlby,--> unable to load one or more of the requested types. Retrive the LoaderExceptions Prpoerty for more information



Unable to get Installer types in the c:\ProgramFiles|Microsoft Visual Studio8\Common7\IDE\Public Assemblies\Microsoft.Practices.ServiceFactory.WCF.Security.Installer.dll assemlby,--> unable to load one or more of the requested types. Retrive the LoaderExceptions Prpoerty for more information



Any other requirement is there to solve this issuee.I hope u can help me regardign this issue..



Thanks and Regards,

Nimesh Prabhakar
Feb 9, 2008 at 7:03 AM
Something isn't getting loaded during install. You can diagnose what using the fusion log viewer. The following blog post has more details of how to do this:

http://www.ademiller.com/blogs/tech/2008/01/gotchas-fusion-log-viewer-your-best-friend-for-assembly-load-errors/

If you can figure out which assembly isn't being loaded then we can probably help further.

Ade