Can't Access DSL Integration Service

Topics: General Discussion Forum, Service Factory Modeling Edition Forum
Oct 18, 2007 at 7:33 PM
I am doing the 15-minute walkthrough. I've installed DSLToolsRedist.msi, ProjectAggregator2.msi, and Web Service Software Factory.

On step 2 of "Complete the Service Contract Model" I get the error "Can't Access DSL Integration Service" when I click the ellipsis in the properties window.

What am I missing?
Developer
Oct 18, 2007 at 7:53 PM
It sounds like the service package may not have been registered. Can you see if this service package is registered by looking for the HKEYLOCALMACHINE\SOFTWARE\Microsoft\VisualStudio\8.0Exp\Packages\{4ca249ec-ba85-4537-b541-d3e4561044dd} registry key?

-b
Oct 18, 2007 at 8:43 PM
I do not have that key. How do I register it?
Developer
Oct 22, 2007 at 5:06 PM
This should have been set during install. Can you try uninstalling and reinstalling the factory?


mrichman wrote:
I do not have that key. How do I register it?

Developer
Oct 22, 2007 at 5:08 PM
Also, I was wondering what environment you are install into to see if we can repro.

Thanks,

-b


mrichman wrote:
I do not have that key. How do I register it?

Oct 22, 2007 at 5:34 PM
I had this problem on both XP and Vista (Busuness) machines. On XP I've uninstalled Web Service Factory and installed it back and that took care of the problem. I will try the same tonight on my Visa machine.
Oct 22, 2007 at 6:22 PM
I uninstalled and reinstalled "Web Service Software Factory.msi". That seems to have worked, but I still don't get that regkey (does that matter?)

I left the "Web Service Software Factory - December 2006 (refresh).msi" as-is.

Otherwise, it looks like it works perfectly now. The 15-Minute Walkthrough script was 100%.
Developer
Oct 23, 2007 at 8:32 PM
I took the key location from a dev version of the factory, the key should really be located

HKLM\SOFTWARE\Microsoft\VisualStudio\8.0\Packages\{4ca249ec-ba85-4537-b541-d3e4561044dd}

Sorry for the confusion.

-b
Oct 31, 2007 at 4:35 PM
Just wanted to add that I got the same error - but after uninstalling and re-installing the service factory it worked!

I am running on Vista.

Thanks

Sujit
Nov 1, 2007 at 10:15 AM
Same as above. Had problems telling me that a resource was missing. Uninstall and install fixed the problem.

w2003 x86

Benny
Jan 18, 2008 at 11:26 PM
I originally installed source, then uninstalled, then installed binary only and got same error.
After uninstalling and re-installing the service factory binary again it worked.